[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Compiling oRTP tests

From: Emeline Hershberger
Subject: Re: [Linphone-developers] Compiling oRTP tests
Date: Fri, 29 Jan 2016 13:28:09 +0100

Hi all
Turns out there is a bug in the library:
In the file '/submodules/linphone/oRTP/src/scheduler.c'
line 34 to 36:
#if defined(_WIN32) && !defined(ORTP_WINDOWS_UNIVERSAL)
Only sets the timer for windows systems
On my machine (Ubuntu 14.04), the sched->timer remains a null pointer
After removing the preprocessor flag, everything works fine.
Gesendet: Donnerstag, 28. Januar 2016 um 17:58 Uhr
Von: "Emeline Hershberger" <address@hidden>
An: address@hidden
Betreff: [Linphone-developers] Compiling oRTP tests

Hi all


I'm trying to incorporate oRTP into a project.

I tried to compile ‘rtpsend.c’ and ‘rtprecv.c’ in ‘oRTP/src/tests’ to test the functionality.

Compiling works fine - [ after altering ortp_set_log_level_mask(ORTP_MESSAGE|ORTP_WARNING|ORTP_ERROR); to ortp_set_log_level_mask(NULL,ORTP_MESSAGE|ORTP_WARNING|ORTP_ERROR); ].

However, when I run any of the the two binaries, a segfault occurs.


Following are my steps:

  1. I downloaded the git repo using ‘git clone git:// --recursive’

  2. I copied the ‘submodules/linphone/oRTP’ folder, as this is the only code I will need from the project.

  3. ‘./’

  4. ‘./configure’

  5. ‘make’

  6. ‘sudo make install’

  7. ‘cd ./src/tests’

  8. ‘gcc -g rtpsend.c -lortp -o send’

  9. ‘gcc -g rtprecv.c -lortp -o recv’

  10. ‘./recv out_file 1337’ -> seg fault

  11. ‘./send out_file 1337’ -> seg fault


Am I compiling the tests correctly?

If so, do you have any pointers how to debug this? With gdb I can only step through the two compiled files.


Thanks in advance.


All the best


_______________________________________________ Linphone-developers mailing list address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]