[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Failing to add Linphone to Freescale BSP image

From: Sandrine
Subject: Re: [Linphone-developers] Failing to add Linphone to Freescale BSP image
Date: Fri, 14 Oct 2016 16:38:22 +0200

Hello Tomas,

It’s a bit late, but thanks for reporting this issue.

I have just fixed the issues in the meta-bc repository, sorry I did not have the chance to work on this before.
Linphone-rings is no longer a runtime dependency as it is not really necessary, unless you want special rings.
In this case you can still install the package separately.

On the master branch : a86345498567070496a97c6a5fac4eda362414b7
On yocto-jethro branch : 20ad994053e62181d5aaee07a29df10a68bf286d

It seems you are using yocto jethro,. If you still have issues when building,
I would suggest you use the yocto-jethro branch of meta-bc with git checkout yocto-jethro
after cloning the repository.

If you run into errors again don’t hesitate to report them, and again my apologies for the delay.
Have a nice week-end!

Best regards,

Sandrine Avakian
Software Engineer

Le 29 sept. 2016 à 13:19, Tomas Olsson <address@hidden> a écrit :

Hi Sandrine and Sylvain,

I can see from the commits that you have contributred alot to the Linphone project and maybe you can help me with some advice.


I get no errors when doing bitbake directly for Linphone:

$ bitbake linphone

But when trying to add Linphone to the bitbake image when building with Yocto for Freescale's BSP gives me problems.

The first one was easy solved:


by changing "libav_9.16.bbappend" to "libav_9.18.bbappend"

But I have not yet solved my next problem....

And It occurs in the later stages when bitbake is building (please see the  attached log.)

Additional information that can be useful:

-> Linphone was downloaded and configured according to
Though I have not turned off video and changed to the GCC settings,

-> Linphone commit ID: cd60b62f6be989a41709d22aa156373de7320e2d - "Update flexisip to version 1.0.10"

-> Freescales yocto project was downloaded with;
repo init -u git:// -b imx-4.1.15-1.0.0_ga

-> I have also attached my local.conf

Best Regards


reply via email to

[Prev in Thread] Current Thread [Next in Thread]