[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] Trouble with RFC 2833 / 4733 DTMF

From: Russell Treleaven
Subject: Re: [Linphone-developers] Trouble with RFC 2833 / 4733 DTMF
Date: Wed, 9 May 2018 08:53:29 -0400

HI Dominic,

I would say this is a bug with Linphone.
Suggest you post a bug at github.

I suspect if speex or opus was negotiated that dtmf would work.
Is that something you can confirm?

BTW I am not affiliated with Linphone.

On Tue, May 8, 2018 at 8:21 PM, Dominic <address@hidden> wrote:
Hi Russel,

I've been there myself, no worries.

I just did another test call with speex 8k enabled (and 16k
disabled) and as expected DTMF worked perfectly. Actually,
looking back at the logs, it looks like speex 8k was enabled in
the successful call I posted (a=rtpmap:96 speex/8000). The only
difference between the one that worked and the one that didn't
was speex 16k was enabled in the one that didn't work.

Let me know if I can provide any other info.

On Fri, 4 May 2018 14:54:56 -0400 Russell Treleaven
<address@hidden> wrote:
> Hi,
> I looked at my response from last night and I can't even tell you what I
> meant to say :).
> Yeah looks to me like like linphone doesn't like dtmf with an iana number
> of 98.
> The extremely typical case is 101.
> can you disable speex 16k but leave speex 8k and see if anything changes?
> Hope I make more sense today.

Thank you,

Linphone-developers mailing list


Russell Treleaven

reply via email to

[Prev in Thread] Current Thread [Next in Thread]