[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Linphone-developers] linphone 4.1.1: Several smaller new issues

From: address@hidden
Subject: [Linphone-developers] linphone 4.1.1: Several smaller new issues
Date: Mon, 28 May 2018 22:51:03 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.8.0

linphone 4.1.1
OpenSuse 15.0
KDE/Plasma 5.12.5

Hi all,

this is my first post, after using linphone (3.10.2) for a while now.

So first of all *** THANK YOU VERY MUCH *** to all of you, who made this nice 
piece of software reality !!!

I have some questions about things who have worked in 3.10.2, and do not, 
anymore, unfortunately.
Not sure if posting several issues in a single list mail is ok for this list, 
several lists do it several ways. If you
prefer one issue per mail, please let me know, for the future!

My issues and questions, sorted by personal priority:

- linphone 3.10.2 have a somewhat "hidden", not easy to find in docs, option 
"linphone -c phone#" enabled me to start linphone calls from whatever 
addressbook app offering a hook to call contact's
phone#. It seems, that this option has been dropped, a pity, at least at first. 
If so, is there any other way to
initiate calls from command line and pass them to linphone GUI?

Background: My family and me are using shared addressbooks on our own Nextcloud 
instance, and as linphone unfortunately
does not offer a cardDAV interface, I've used e.g. cardDAV-enabled kAdressbook 
in KDE/Plasma, which offers the mentioned

Having said this, 2 general questions about contacts in linphone:

- 3.10.2 has menu items for reading contacts via vcard or vcf, but I was 
getting a message that my linphone version was
compiled without support for this. Completely can't find this import option in 
4.1.1, also dropped?
- 3.10.2 offered also support for LDAP. Which IMHO would be a little overkill 
for private, non-enterprise contacts in a
Nextcloud, but if it would be the only option, fine to give it a try. But I 
can't also find in 4.1.1, also dropped?

Reason for these 2 questions is that it would be nice to get contact's name for 
incoming calls, if existing.

- linphone 4.1.1 does not offer anymore the option to type a phone# into the 
text field in upper area and start to dial
with <return>. Typed phone# disappears, without further notice. Worked fine in 
3.10.2 :-( Typing "sip:address@hidden"
works, but IMHO really inconvenient. Esp. as currently only manually added 
contacts seems to be possible, so I have to
type all phone# manually.

- linphone 4.1.1 has an IMHO much nicer looking GUI than before, but I'm 
missing some buttons etc., maybe
incompatibility to the current KDE/Plasma version? E.g. the HOME screen: Where 
to click to "Invite your friends" or
"Account assistant" - both not available. Another example: Klicking in the 
upper left corner opens a dialogue box,
dropdowns for "presence status" and "active account". No buttons for "ok", 
"cancel" or similar. "ESC" does not work, no
idea how to leave this dialogue at first, only "kill -9" helped ... Found in 
the meantime, that there's an "invisible"
click area in the lower middle part of this dialogue :-)

If any screenshots would help, please let me know!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]