[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-developers] linphone-daemon not responding to sound card c

From: John Whelan
Subject: Re: [Linphone-developers] linphone-daemon not responding to sound card config
Date: Tue, 31 Mar 2020 11:49:51 -0400
User-agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 PostboxApp/7.0.12

Just a comment in Windows the sound card drivers are problematic for everything.  If your machine has realtek built in you might like to think about using it.  The drivers are much more stable.

Cheerio John

Iain Mott wrote on 2020-03-31 10:17 AM:
Dear developers,

I am using linphone-daemon to make calls and transfers on a Linux machine running Asterisk. It is important that I use Jack for the audio. With Linphone 4.1.1, this works without problems and the PulseAudio Jack sink/source are delectable in the preferences. I have not however managed to use linphone-daemon with jack.

I start the daemon with:

linphone-daemon --config ~/.linphonerc

The config file is loaded and the sip device to make and receive calls is registered correctly.

The sound device part of the [sound] configuration however in .linphonerc seems to be being ignored and the audio used is always the internal hardware.

In linphonec, "soundcard list" yields:

0: PulseAudio: Áudio interno Estéreo analógico
1: PulseAudio: Scarlett 18i20 USB Multicanal
2: PulseAudio: Jack sink (PulseAudio JACK Sink)
3: PulseAudio: Jack source (PulseAudio JACK Source)
4: ALSA: default
5: ALSA: HDA Intel PCH

So i wish to use device 2 for playback and ringer and device 3 for capture.

I have tried many configurations including:


I've also tried , for the device settings:

playback_dev_id=PulseAudio Jack sink (PulseAudio JACK Sink)
ringer_dev_id=PulseAudio Jack sink (PulseAudio JACK Sink)
capture_dev_id=PulseAudio Jack source (PulseAudio JACK Source)


playback_dev_id=PulseAudio Jack sink
ringer_dev_id=PulseAudio Jack sink
capture_dev_id=PulseAudio Jack source

And further, I've tried various other device combinations but nothing changes. Other changes, such as to the ring tone file, do register correctly.

Can anyone please help?



Linphone-developers mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]