[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lmi] lmi tests under cygwin

From: Greg Chicares
Subject: Re: [lmi] lmi tests under cygwin
Date: Wed, 02 Nov 2005 18:39:13 +0000
User-agent: Mozilla Thunderbird 1.0.2 (Windows/20050317)

On 2005-11-1 18:12 UTC, Vadim Zeitlin wrote:
> On Tue, 01 Nov 2005 17:40:51 +0000 Greg Chicares <address@hidden> wrote:
> GC> On 2005-11-1 16:22 UTC, Vadim Zeitlin wrote:
> GC> > 
> GC> >  I've tried to run tests under cygwin, as promised, and many of them 
> fail
> GC> > with this exception:
> GC> > 
> GC> >         Not all alert function pointers have been set.
> GC> > 
> GC> > I didn't have time to look into this in details yet but maybe you 
> already
> GC> > know what is it due and where should I concentrate my efforts?
> GC> 
> GC> I don't know what would cause it. Which tests fail this way? The 'alert'
> GC> facility has its own unit test, 'alert_test.cpp'; does that one fail?
>  Yes, it does fail and, looking in the code, it seems that it does it just
> because set_alert_functions() is never called. Which, in turn, surely
> happens because ensure_setup in alert_cli.cpp is not initialized because
> the relevant object file must be discarded by the linker as nothing uses
> it. I didn't know GNU ld did it but I do know that MS link.exe does it and
> we even have special macros in wx/link.h which are used to work around this
> "feature". So while I can try to fix it at Makefile.am level somehow, I
> think it would be better to do it in the source.

Let's address only this part of your message today, because it's
the worst problem. I agree that we should try to fix it at the
source: if it's a linker problem, then it doesn't depend on
autotools at all.

You say wx has worked around this. I don't find the file you
mention, though:

  C:/wxWidgets-2.5.4/include[1]$ls **/link.h
  zsh: no matches found: **/link.h

Would you quote the macro in reply, please?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]