[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lmi] How to build lmi from source on GNU/Linux

From: Greg Chicares
Subject: Re: [lmi] How to build lmi from source on GNU/Linux
Date: Sat, 20 Sep 2008 14:06:23 +0000
User-agent: Thunderbird (Windows/20080708)

On 2008-05-06 07:22Z, Vaclav Slavik wrote:
> On Tue, 2008-05-06 at 01:35 +0000, Greg Chicares wrote:
>> The other day I spoke with someone who wants to build lmi on a
>> GNU/Linux system. Do we have simple step-by-step instructions for
>> that?
> See README.auto -- it's the usual stuff for autotools-based makefiles:

I don't claim to understand autotools, but I thought I might try
using them experimentally--e.g., so I can help with this problem:
or avoid creating problems like this:

So I tried to follow 'README.auto', but I got stuck. That file says
I need:

| a) GNU autoconf >= 2.56 (2.56 under mingw and 2.59 under cygwin are known to 
| b) GNU automake >= 1.5 (at least; 1.7.9 and 1.9.6 known to work)
| c) GNU libtool >= 1.5 (1.5.20 known to work)

so these Cygwin versions seem okay:

$autoconf --version | head --lines=1
autoconf (GNU Autoconf) 2.61
$automake --version | head --lines=1
automake (GNU automake) 1.10.1
$libtool --version | head --lines=1
ltmain.sh (GNU libtool) 1.5.25a (1.1220.2.458 2007/06/30 09:32:00)

| alternative: ensure that "wx" environment variable exists and points to the
| (uninstalled) wx source tree which you want to use and set ACLOCAL_AMFLAGS
| environment variable to "-I $wx".

This alternative sounds simple, so I point to the wx sources
that I use for non-autotools builds (simply an extracted tarball
downloaded from wxwidgets.org):

$export wx=/opt/lmi/wx-scratch/wxWidgets-2.8.7
$export ACLOCAL_AMFLAGS="-I $wx"

| After a fresh cvs checkout you need to run autogen.sh once.

I first tried running it outside the source directory, but...

Please run this script from the lmi source directory.

...well, okay:

$cd /lmi/src/lmi
Setting up build system for lmi:
 - aclocal
 - libtoolize
 - autoconf
configure.ac:82: error: possibly undefined macro: AC_MSG_ERROR
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
Automatic build files setup failed!

Line 82 of 'configure.ac' is:
                   *) AC_MSG_ERROR(bad value ${enableval} for --enable-debug) ;;
so I fear I'm two levels deep in problems I don't understand:
 - I didn't specify '--enable-debug'; and
 - I don't know why AC_MSG_ERROR might be undefined
and it seems like a good time to ask for help. The most common
response to questions like this
seems to suggest a version conflict.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]