[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lmi] An irreproducible anomaly

From: Vadim Zeitlin
Subject: Re: [lmi] An irreproducible anomaly
Date: Thu, 16 Jun 2016 03:08:13 +0200

On Tue, 14 Jun 2016 21:50:31 +0000 Greg Chicares <address@hidden> wrote:

GC> I only saw it once myself, when I was trying to reproduce it while talking
GC> with Kim on the telephone. I didn't have lmi open at all, so I started a
GC> single instance just to see whether I could reproduce the anomaly. I ran
GC> through a broad variety of steps before I saw anything weird--e.g.:
GC>  - editing the field in-place in the census manager
GC>  - pasting into it

 On a completely separate note, when doing this with some random text
(which turned out to be a part of another email), I got the following
message box:

        Symbol table for class class Input ascribes no member named 'VZ> '.

This is true, as far as it goes, but I'd suggest that saying "Clipboard
doesn't contain valid census data" could be less incomprehensible to the
end users...

GC>  - copying from it and pasting back in repeatedly
GC>  - toggling "Census | {Fixed,Variable} column width"
GC>  - resizing the field with the mouse
GC> and then popping up the tabbed dialog by
GC>  - right-clicking the same cell and choosing "Edit cell..."
GC>  - right-clicking a different cell and choosing "Edit cell..."
GC>  - clicking the magnifying-glass button on the toolbar
GC>  - equivalent menu commands with the mouse, with alt-key accelerators,
GC>      and with Ctrl-Shift-Whatnot
GC> but I've repeated all those things numerous times and have seen the
GC> anomaly only once.

 I probably don't have any better hope to reproduce the bug than you do, so
I didn't try redoing all of the above, so instead I tried modifying
wxWidgets sources to, first, avoid dismissing the editor while showing the
dialog and, then, to call it from inside wxYield(). Unfortunately I still
couldn't see the problems you described, so it looks like the only theory I
had was wrong and I really don't know what else to do.

GC> If you can think of some extra sanity check that we might build in,

 My only remaining idea is that, somehow, wxTheApp().IsActive() is always
false in MvcContoller::UponUpdateUI(). But I really don't see how could
this happen nor what could we do to check for it. The best would, actually,
be just to remove this check anyhow, but this would require changes to
focus management, as discussed in the link in the comment just before this
check, and I'm not sure you're willing to do this right now...

 Sorry but I'm just completely stumped here,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]