[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lmi] Headless GUI tests on corporate server

From: Greg Chicares
Subject: Re: [lmi] Headless GUI tests on corporate server
Date: Sat, 13 Nov 2021 22:07:37 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.13.0

On 11/13/21 5:37 PM, Greg Chicares wrote:
> I'll start a separate thread for server issues.

Here's a transcript of a session on our corporate server:

/home/REDACTED[0]$schroot --chroot=chroot:lmi_bookworm_4
/home/REDACTED[0]$Xvfb :1 -screen 0 1280x1024x8 &
[1] 103327
/home/REDACTED[0]$_XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to 
/home/REDACTED[0]$ls -ld /tmp/.X11-unix
drwxrwxrwt. 2 mm53451 REDACTED 16 Nov 13 14:49 /tmp/.X11-unix
/home/REDACTED[0]$kill 103327
[1]  + done       Xvfb :1 -screen 0 1280x1024x8
/home/REDACTED[0]$sudo chown root:root /tmp/.X11-unix

Oops, I had forgotten that, while I'm a sudoer on the
redhat host, I never did find a way to use sudo in a
chroot on this server. Let's rule out this problem:

/home/REDACTED[1]$sudo su -
Last login: [date redacted]
/root[0]#ls -ld /srv/chroot/lmi_bookworm_4/tmp/.X11-unix
drwxrwxrwt. 2 REDACTED REDACTED 6 Nov 13 09:50 
/root[0]#chown root:root /srv/chroot/lmi_bookworm_4/tmp/.X11-unix
/root[0]#ls -ld /srv/chroot/lmi_bookworm_4/tmp/.X11-unix
drwxrwxrwt. 2 root root 6 Nov 13 09:50 /srv/chroot/lmi_bookworm_4/tmp/.X11-unix

Now, back into the chroot as our normal user:

/home/REDACTED[0]$schroot --chroot=chroot:lmi_bookworm_4
/home/REDACTED[0]$cd /opt/lmi/src/lmi
/opt/lmi/src/lmi[0]$Xvfb :1 -screen 0 1280x1024x8 &
[1] 104245
/opt/lmi/src/lmi[0]$echo $DISPLAY

At first, I tried using that value of $DISPLAY, ":0.0",
which is wrong:

/opt/lmi/src/lmi[0]$DISPLAY=:0.0 wine /opt/lmi/bin/wx_test --ash_nazg 
--data_path=/opt/lmi/data --test log_error
0009:err:winediag:nodrv_CreateWindow Application tried to create a window, but 
no driver could be loaded.
0009:err:winediag:nodrv_CreateWindow Make sure that your X server is running 
and that $DISPLAY is set correctly.
In file /opt/lmi/src/lmi/third_party/wx/src/msw/utils.cpp at line 1563: 
'CreateWindow() in wxCreateHiddenWindow' failed with error 0x00000012 (No more 
In file /opt/lmi/src/lmi/third_party/wx/src/msw/mdi.cpp at line 1396: 
'CreateWindowEx(MDI client)' failed with error 0x00000000 (Success.).
In file /opt/lmi/src/lmi/third_party/wx/src/msw/window.cpp at line 4052: 
'CreateWindowEx("wxMDIFrameNR", flags=02cf0000, ex=00000000)' failed with error 
0x0000007a (Insufficient buffer.).
In file /opt/lmi/src/lmi/third_party/wx/src/msw/mdi.cpp at line 1499: 
'SendMessage(WM_MDISETMENU)' failed with error 0x00000578 (Invalid window 
In file /opt/lmi/src/lmi/third_party/wx/src/msw/window.cpp at line 4052: 
'CreateWindowEx("ToolbarWindow32", flags=52008100, ex=00000000)' failed with 
error 0x0000057e (Can't create top-level child window.).
In file /opt/lmi/src/lmi/third_party/wx/include/wx/msw/private.h at line 380: 
'GetClientRect' failed with error 0x00000578 (Invalid window handle.).

Instead, we want the DISPLAY value specified in this command:
  Xvfb :1 -screen 0 1280x1024x8 &
and that seems to get us farther:

/opt/lmi/src/lmi[0]$DISPLAY=:1 wine /opt/lmi/bin/wx_test --ash_nazg 
--data_path=/opt/lmi/data --test log_error
Assertion '"Assert failure"' failed
(incorrect bitmap type in wxBitmap::GetRawData()).
[file /opt/lmi/src/lmi/third_party/wx/src/msw/bitmap.cpp, line 1423]

The string "incorrect bitmap type" doesn't occur anywhere in
this mailing list's two decades of archives. Vadim, have you
any idea what could cause that?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]