[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ltib] LTIB on Gentoo

From: Ken Gilmer
Subject: Re: [Ltib] LTIB on Gentoo
Date: Thu, 1 Feb 2007 09:34:37 -0500

Hey Stuart,

Yeah, my has the Gentoo line. I've confirmed that "/ usr/portage" exists on my machine:

$ ls -ld /usr/portage
drwxr-xr-x 158 root root 4096 Jan 31  2007 /usr/portage

And that /usr/include/[gc]++ does not (assuming there is no string substitution in there):

$ ls -ld /usr/include/*\+\+
ls: cannot access /usr/include/*++: No such file or directory

But if I'm reading the error and Perl right, shouldn't the problem be with the preceeding check, the one for 'libstdc++'? Here is my libstdc check:

$ ls -ld /usr/lib/libstdc++*
drwxr-xr-x 2 root root 4096 Apr 28  2006 /usr/lib/libstdc++-v3

I looked up the glob() function, and extracted that particular code into a script and ran it:

$ cat /tmp/
print glob('/usr/lib/libstdc++*');

$ perl /tmp/

So it seems the check requires more than one return here. If I run the same script on my FC5 box, I get this:

# perl

Since I do not know why more than one is required to be valid, I cannot suggest a fix for this problem. Throwing caution to the wind, I changed the test such that one file expansion would pass. It now seems to be running, but I'm not sure if it worked or not. I'll respond back once I know.

Here is my box version. It is a recent install and should be reasonably up to date.

$ uname -a
Linux localhost 2.6.15-gentoo-r5 #1 SMP Mon Feb 13 20:23:47 UTC 2006 i686 Celeron-A GenuineIntel GNU/Linux


On Feb 1, 2007, at 5:07 AM, Stuart Hughes wrote:

Hi Ken,

Can you check that the file: bin/ has got this in it at line
563.  This was recently submitted.

'libstdc++-devel'=> sub { return system_nb("ls -ld /usr/include/ [gc]++* &>/dev/null") == 0 || (-e "/usr/portage") # Gentoo hack

Basically the test is looking for some g/c++ headers in /usr/ include as
evidence of c++ development being installed.  The extra bit that was
added was for Gentoo, apparently this does not have these files, so the
idea is that if your system has /usr/portage (e.g. is Gentoo) then the
test just passes.

If you do have /usr/portage on your system it should work.  If not I
need to come up with some other test for Gentoo. Maybe you could take a
look and see what might be a useful telltale.

Regards, Stuart

On Wed, 2007-01-31 at 15:37 -0500, Ken Gilmer wrote:
Hello :)

   I'm trying to get LTIB up and running on a Gentoo box.  I've used
the netinstall perl script from the site.  Initially, LTIB complained
about several packages not installed.  I was able to install all but
one: libstdc++.  Gentoo's package manager has an entry for libstdc++,
yet after emerging that package, LTIB still does not see it:

$ ./ltib
Don't have HTTP::Request::Common
Don't have LWP::UserAgent
Cannot test proxies, or remote file availability without both
HTTP::Request::Common and LWP::UserAgent

ltib cannot be run because one or more of the host packages needed
to run it are either missing or out of date.

Please install/upgrade these packages and then re-try.

Package                Minimum ver   Installed info
-------                -----------   ---------------
libstdc++              0             not installed
Died at ./ltib line 1412.

Started: Sat Jan 20 11:25:37 2007
Ended:   Sat Jan 20 11:25:38 2007
Elapsed: 1 seconds

Build Failed

Exiting on error or interrupt

Has anyone run into this before?  Any suggestions on how to resolve
this dependency issue?


LTIB home page:

Ltib mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]