[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Ltib] LTIB on Gentoo

From: Ken Gilmer
Subject: Re: [Ltib] LTIB on Gentoo
Date: Fri, 2 Feb 2007 15:35:56 -0500

Hey Stuart, I first tried the "exit 0" fix. Ltib halts at the same place. Then I tried the patch from and got the same result, and finally the one from redhat. In all cases the error seems to look the same in the log file:

++ sed -e 's,/usr$,,'
+ etc=/opt/ltib/etc
+ mkdir -p /tmp/rpm-fs//opt/ltib/pkgs
+ chmod 777 /tmp/rpm-fs//opt/ltib/pkgs
+ mkdir -p /tmp/rpm-fs//opt/ltib/var/tmp
+ chmod 777 /tmp/rpm-fs//opt/ltib/var/tmp
+ chmod 777 /tmp/rpm-fs//opt/ltib/usr/src/rpm/BUILD /tmp/rpm-fs//opt/ ltib/usr/src/rpm/RPMS /tmp/rpm-fs//opt/ltib/usr/src/rpm/SOURCES /tmp/ rpm-fs//opt/lti
b/usr/src/rpm/SPECS /tmp/rpm-fs//opt/ltib/usr/src/rpm/SRPMS
+ chmod 777 /tmp/rpm-fs//opt/ltib/usr/src/rpm/RPMS/athlon /tmp/rpm- fs//opt/ltib/usr/src/rpm/RPMS/i386 /tmp/rpm-fs//opt/ltib/usr/src/rpm/ RPMS/i486 /tmp/rp m-fs//opt/ltib/usr/src/rpm/RPMS/i586 /tmp/rpm-fs//opt/ltib/usr/src/ rpm/RPMS/i686 /tmp/rpm-fs//opt/ltib/usr/src/rpm/RPMS/noarch
+ chmod -x /tmp/rpm-fs//opt/ltib/usr/lib/rpm/perl.req
+ cd /tmp/rpm-fs//opt/ltib/usr/lib/rpm
+ perl -pi -e 's,([ :])/usr/lib/rpm,\1/opt/ltib/usr/lib/rpm,g' cpanflute cpanflute2 find-provides find-provides.perl find-requires find-requires.perl mac
ros rpmpopt-4.0.4 rpmrc trpm
+ cd -
+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip
+ /usr/lib/rpm/brp-strip-static-archive
+ /usr/lib/rpm/brp-strip-comment-note
+ /usr/lib/rpm/brp-nobuildrootpath
Processing files: rpm-fs-4.0.4-1
Build time for rpm-fs: 16 seconds

Failed building rpm-fs
Died at ./ltib line 2187.

Started: Fri Feb  2 10:15:17 2007
Ended:   Fri Feb  2 10:17:01 2007
Elapsed: 104 seconds

These packages failed to build:
Build Failed


Is there a specific version of RPM I could install to resolve this issue?

Thanks again,

On Feb 2, 2007, at 8:50 AM, Stuart Hughes wrote:

Hi Ken,

I looked into this and it looks like a bug in rpm in the version you
have on your host:

I took a look at the script and I can't see and easy way to turn it off
from the spec file.

Either try to get an update for this (the second link looks promising)
or you can you try simply putting an 'exit 0' at the bottom of the
script /usr/lib/rpm/brp-nobuildrootpath

Once you've done that, try re-running ltib.

Let me know how it goes.

Regards, Stuart

On Thu, 2007-02-01 at 10:33 -0500, Ken Gilmer wrote:

   Here is the file.  Hope it helps.


Hi Ken,

Could you send me the whole host_config.log file off the list, it
like just above there was some message about macros rpmpopt-4.0.4 that may give some ideas. I suspect there may be a package missing on your
host installation that wasn't properly checked by ltib.

Regards, Stuart

reply via email to

[Prev in Thread] Current Thread [Next in Thread]