[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Ltib] Re: Install Dillo Problem

From: Vic
Subject: [Ltib] Re: Install Dillo Problem
Date: Fri, 1 Oct 2010 01:37:29 -0700

Hi Stuart,

Gee, I feel stupid. <bg> I assumed it auto selected all dependencies as it did some. Anyway, the build was successful after X11 install but when I run dillo it's looking for <>.such as

address@hidden /]# dillo
dillo: error while loading shared libraries: cannot open shared object file: No such file or directory

Is this a wrong path issue? What should I do now as I can't seem to find a standalone RPM for it. Is there any documentation I should be reading to get thru this without bothering you so much?

Many Thanks,

Date: Thu, 30 Sep 2010 21:18:13 +0100
From: Stuart Hughes <address@hidden>
Subject: Re: [Ltib] Install Dillo problem
To: Vic <address@hidden>
Cc: ltib mail <address@hidden>
Message-ID: <address@hidden>
Content-Type: text/plain; charset=ISO-8859-1

Hi Vic,

It may be that you do not have X selected in your configuration.

To check this, run:

$ ./ltib -m config

// quick way,

type s and in the search dialog enter Xorg

make sure the cross is marked in :

(X) X.Org 7.3

// alternative longer way

scroll down and select --- Package selection / Package list ---->

scroll down and find:

[ ] xfsprogs
  X11  --->
[ ] yaffs_utils

Highlight X11 and click enter, make sure for Install X11 it says:
(X.Org 7.3)
if not, click enter and select it.

When you're done, save/exit and then run:

$ ./ltib

Regards, Stuart

Vic wrote:

I'm new to Linux and just bought an EA LPC3250. I finished the "Getting
Started with Linux on the LPC3250 OEM board" guide and had a successful
build using the default configuration but only when I use
instead of the 2.6.34 kernel. My objective is to run a Web browser and
so I selected dillo from the LTIB configuration package list. When I run
./ltib, it failed on libXrender as seen below. and even if I deselect
dillo, the libXrender error stays.

1. How do recover from this? It seems the compilation messages have
enough info to tell me what exactly is causing the issue.
2. What and Where is the file that has the environment settings? The
guide mentioned about configuration settings such as CONFIG_NET and
CONFIG_LPC32XX_MII but didnt mention where they are set.

Any help shall be very much appreciated.


here's the trail
checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
checking for arm-linux-pkg-config... no
checking for pkg-config... /opt/ltib/usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for X... configure: error: Package requirements (x11) were not met:

No package 'x11' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables X_CFLAGS
and X_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

error: Bad exit status from /home/user/ltib/tmp/rpm-tmp.60081 (%build)

RPM build errors:
    Bad exit status from /home/user/ltib/tmp/rpm-tmp.60081 (%build)
Build time for libXrender: 16 seconds

Failed building libXrender

f_buildrpms() returned an error, exiting

Started: Thu Sep 30 02:37:46 2010
Ended:   Thu Sep 30 02:41:40 2010
Elapsed: 234 seconds

VERSION          : 10.1.1
CVS_VERSION      : $Revision: 1.71 $ (Savannah)
PLATFORM         : ea3250
GNUTARCH         : arm
TOOLCHAIN        : tc-fsl-x86lnx-armeabi-nptl-4.1.2-3.i386.rpm
TOOLCHAIN_CFLAGS : -O2 -fsigned-char -mfloat-abi=softfp -mfpu=vfp

These packages failed to build:

Build Failed

Exiting on error or interrupt
address@hidden:~/ltib$ <mailto:address@hidden:~/ltib$>


LTIB home page:

Ltib mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]