[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Ltib] Re: Install Dillo Problem

From: Vic
Subject: [Ltib] Re: Install Dillo Problem
Date: Wed, 6 Oct 2010 19:05:56 -0700

Hi Kevin,

I tried an old ltib renamed directory earlier and confirmed that there was a valid 3.2 inch LCD display selected but despite that, the compile for kernel 2.6.34 had the error. Plus I'm wondering why it compiled fine in However, after I 'cvs up' the wouldnt compile either. Then I tried to do a reinstall and found out that there was this line 69 issue on the install. I tried installing on another PC and it's the same issue, can't install LTIB.

Any idea why this is so?


----- Original Message ----- From: "Kevin Wells" <address@hidden>
To: "Vic" <address@hidden>
Cc: "ltib mail" <address@hidden>
Sent: Tuesday, October 05, 2010 6:39 PM
Subject: RE: Install Dillo Problem

Hi Vic,

It sounds like something might have been edited in the kernel
config file. You'll need to selected one of the displays in
the kernel config menu in
System Type->Embedded Artists Display Selection -->


-----Original Message-----
From: Vic [mailto:address@hidden
Sent: Tuesday, October 05, 2010 9:18 PM
To: Kevin Wells
Cc: ltib mail
Subject: Re: Install Dillo Problem


 Here's a more complete error trace of ./ltib --leavesrc xorg-server


 HOSTCC  scripts/bin2c
scripts/kallsyms.c: In function 'read_symbol':
scripts/kallsyms.c:112: warning: ignoring return value of 'fgets',
with attribute warn_unused_result
  MKELF   scripts/mod/elfconfig.h

 LD      arch/arm/common/built-in.o
arch/arm/kernel/return_address.c:61:2: warning: #warning "TODO:
return_address should use unwind tables"
  CC      arch/arm/kernel/setup.o
  CC      arch/arm/mm/iomap.o
  GEN     usr/initramfs_data.cpio
  CC      arch/arm/kernel/signal.o
  CC      arch/arm/mm/fault-armv.o
  CC      arch/arm/mach-lpc32xx/timer.o
  AS      usr/initramfs_data.o
  CC      arch/arm/mm/flush.o
arch/arm/mm/init.c: In function 'mem_init':
arch/arm/mm/init.c:678: warning: format '%08lx' expects type 'long
int', but argument 12 has type 'unsigned int'
  LD      usr/built-in.o

AS      arch/arm/mm/proc-arm926.o
arch/arm/kernel/unwind.c:34:2: warning: #warning Your compiler is too
it is known to not compile ARM unwind support.
arch/arm/kernel/unwind.c:35:2: warning: #warning Change compiler or
ARM_UNWIND option.
  AS      arch/arm/kernel/debug.o

CC      ipc/util.o
arch/arm/mach-lpc32xx/ea3250.c: In function 'lpc32xx_clcd_setup':
arch/arm/mach-lpc32xx/ea3250.c:313: error: 'conn_lcd_panel' undeclared
(first use in this function)
arch/arm/mach-lpc32xx/ea3250.c:313: error: (Each undeclared identifier is
reported only once
arch/arm/mach-lpc32xx/ea3250.c:313: error: for each function it appears
arch/arm/mach-lpc32xx/ea3250.c: In function 'writeToReg':
arch/arm/mach-lpc32xx/ea3250.c:377: warning: unused variable 'buf'
make[1]: *** [arch/arm/mach-lpc32xx/ea3250.o] Error 1
make: *** [arch/arm/mach-lpc32xx] Error 2
make: *** Waiting for unfinished jobs....
  CC      fs/file_table.o

  CC      fs/proc/page.o
  LD      fs/proc/proc.o
  LD      fs/nfs/nfs.o
  LD      fs/proc/built-in.o
  LD      fs/nfs/built-in.o
  LD      fs/built-in.o
error: Bad exit status from /home/user/ltib/tmp/rpm-tmp.13411 (%build)

RPM build errors:
    Bad exit status from /home/user/ltib/tmp/rpm-tmp.13411 (%build)
Build time for kernel-2.6.34-lpc32xx: 201 seconds

Failed building kernel-2.6.34-lpc32xx

f_buildrpms() returned an error, exiting

Started: Tue Oct  5 20:12:24 2010
Ended:   Tue Oct  5 20:16:01 2010
Elapsed: 217 seconds

VERSION          : 10.1.1
CVS_VERSION      : $Revision: 1.71 $ (Savannah)
PLATFORM         : ea3250
GNUTARCH         : arm
TOOLCHAIN        : tc-fsl-x86lnx-armeabi-nptl-4.1.2-3.i386.rpm
TOOLCHAIN_CFLAGS : -O2 -fsigned-char -mfloat-abi=softfp -mfpu=vfp

These packages failed to build:

Build Failed

Exiting on error or interrupt
----- Original Message -----
From: "Kevin Wells" <address@hidden>
To: "Vic" <address@hidden>
Cc: "ltib mail" <address@hidden>
Sent: Tuesday, October 05, 2010 10:26 AM
Subject: RE: Install Dillo Problem

Hi Vic,

You'll need to use the 2.6.34 port. It has the changes you need.
I just did a test build of 2.6.34 with all updates from SVN and
was able to build the kernel without any errors. Can you post
your errors?

You need to apply that patch on the kmode.c file in the
./ltib/rpm/BUILD/xorg-server folder unpacked by LTIB. I believe
you can install the source with './ltib --leavesrc xrog-server'.


> -----Original Message-----
> From: Vic [mailto:address@hidden
> Sent: Tuesday, October 05, 2010 1:28 AM
> To: Kevin Wells
> Cc: ltib mail
> Subject: Re: Install Dillo Problem
> Kevin,
> Ok, Just want to confirmto avoid any mistakes. I can't successfully
> compile
> in 2.6.34 and so I renamed the /BUILD/ instead. It doesnt have
> be
> on 2.6.34,right?
> Then the X11 source that I have to install in ubuntu 9.04 MUST to be
> 7.3,right?
> Then I should apply your display patch on kmode.c,right?
> Thanks,
> Vic
> ----- Original Message -----
> From: "Kevin Wells" <address@hidden>
> To: "Vic" <address@hidden>; <address@hidden>
> Sent: Monday, October 04, 2010 9:56 AM
> Subject: RE: Install Dillo Problem
> Hi Vic,
> You'll need to do a 'cvs up' in your ltib directory to get
> the changes. You should also rename or delete the
> linux-2.6.34 directory in ./rpm/BUILD so the changes will
> be correctly installed.
> The easiest way to install the X11 changes is to install the
> Xorg-server source and then manually apply the changes to
> the file.
> Rebuild all and you should be ok. Install a USB mouse into
> the USB host port, boot your board to Linux, and then....
> Xfbdev -mouse mouse &
> export DISPLAY=localhost:0.0
> dillo &
> It worked great over here, but the rendering has problems on
> some pages with some large blank regions. You might be able
> to get some tuning info from Dillo's website. The performance
> was quite good.
> Kevin
> > -----Original Message-----
> > From: Vic [mailto:address@hidden
> > Sent: Sunday, October 03, 2010 8:24 PM
> > To: address@hidden
> > Cc: Kevin Wells
> > Subject: Re: Install Dillo Problem
> >
> > Hi Kevin,
> >
> > How do I update the SVN code and install the X11 patch?
> >
> > Thanks,
> > Vic
> >
> >
> >

reply via email to

[Prev in Thread] Current Thread [Next in Thread]