[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Ltib] mmcblk0: error -115 sending stop command

From: Reer, Carolyn (SA-1)
Subject: RE: [Ltib] mmcblk0: error -115 sending stop command
Date: Thu, 18 Nov 2010 08:57:02 -0500

Thanks. But I can’t change the FAT16 partition. I can’t write to it as FAT16. And I can’t change or delete it using fdisk. I tried 2 different cards.


Carolyn Reer

From: Miguel Angel Ajo Pelayo [mailto:address@hidden
Sent: Thursday, November 18, 2010 6:09 AM
To: Reer, Carolyn (SA-1); address@hidden
Subject: Re: [Ltib] mmcblk0: error -115 sending stop command


Hi Carolyn,

  It's a different problem, we are talking about the LPC31xx NXP processor MMC support,
that seems to be broken with NXP last patches (not related to MPCxxxxx)

  For your case, dont know, try to make an ext2 partition (using fdisk, and then mkfs.ext2) on the SD
card and put your rootfs inside, then at boot pass the boot parameters to kernel(for the 1st partition):
root=/dev/mmcblk0p1 rootdelay=2

Good luck!
El 17/11/2010 17:42, Reer, Carolyn (SA-1) escribió:

This sounds like same problem I am having:

Has anyone booted the kernel from SDHC card?

I have 2.6.28 kernel built for Freescale MPC8536E and booting from NFS.

I would like to copy the kernel & file system over to SD card to eliminate NFS from my Ethernet traffic timing tests.

I have tried 2-4GB SDHC cars and they are pre-formatted with W95 FAT16 partitions.

I can mount the partition:

mount /dev/mmcblk0p1 /mnt/tmp/

But I can’t write to it.


I tried using fdisk to delete the partition and make a new linux partition; tried changing the FAT16 partition to linux partition.

But I can’t save the changes.


I was able to mount the drive:

mount /dev/mmcblk0 /mnt/tmp/

But I have less than 256MB to write to.



Carolyn Reer



Carolyn Reer

From: address@hidden [mailto:address@hidden] On Behalf Of Miguel Angel Ajo Pelayo
Sent: Wednesday, November 17, 2010 11:35 AM
To: casper iway
Cc: address@hidden
Subject: Re: [Ltib] mmcblk0: error -115 sending stop command


No, removing BURST_DMA didn't fix it, it's something related to that R4 patch,
not sure what's wrong with it.

Kevin, do you know who's the author of the lpc313x_mmc.c host driver in R4 patch?

El 17/11/2010 17:20, Miguel Angel Ajo Pelayo escribió:

Not sure if my comments will fix it,

I'm facing the exact same problem after switching to the MMC driver included in the R4 patch
for the LPC313x kernel from NXP.

I will make some tests to discover what's wrong, if I fix it I will tell you.


El 15/11/2010 2:59, casper iway escribió:

hi Stuart,

    its Casper/Kasper whichever... Nolan is my colleague, he forgot to put my name instead..
    Anyway, i do have enough (free) space, i have 1GB SD card and the Root Filesystem only taken up 250MB. I also mount the card on an Ubuntu laptop with SD card reader and i think its OK (i guess!), since i dont see any warning and i could mount, umount, copy, delete,etc... But im not really sure, because this is not a brand new card, i once use this card for my old camera. Is there any tool i can use to fully test my SD cards integrity or something? as i am not familiar with any tools for SD card.
    I may try Miguel's idea first and if i got the same problem then i may purchase a new SD card for further testing...




On Sat, Nov 13, 2010 at 10:43 PM, Stuart Hughes <address@hidden> wrote:

Hi Casper (Nolan?),

You need to worry about these messages.  Make sure you have free space
on the device.  Also mount it in another machine (with a card reader)
and check to see that there is nothing wrong with the device itself.

Regards, Stuart

casper iway wrote:
> Hello guyz, i just work back with my LPC3131 board. I was able to setup
> a Remote System Explorer (TM/RSE) before with this board, but that was
> using NFS mount Root Filesystem. Now i planning to boot the Filesystem
> in my MMC/SD card, but the problem is, but during booting up of ARM
> Linux (Kernel in NAND, RFS in MMC card),  i could see a lot of warning
> message something like "*cp: write error: No space left on device*". But
> it will probably and successfully continue to boot ARM Linux but then
> after a while i could read lots of warning like "*mmcblk0: error -115
> sending stop command, response 0xc00, card status 0xe00*".  Those
> warning always shown every sometime, but doesn't really affect the
> system because i could still do all Linux commands like browse
> directory, top, etc... But i just got annoyed with those warnings as
> they are shown almost every minute...
> Did someone knows this problem?? Please help...
> regards,
> Nolan

LTIB home page:
Ltib mailing list

Miguel Angel Ajo Pelayo
+34 636 52 25 69
skype: ajoajoajo

Miguel Angel Ajo Pelayo
+34 636 52 25 69
skype: ajoajoajo

Miguel Angel Ajo Pelayo
+34 636 52 25 69
skype: ajoajoajo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]