[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Ltib] host side questions

From: Aaron Wegner
Subject: [Ltib] host side questions
Date: Fri, 19 Nov 2010 11:34:44 -0500
User-agent: SquirrelMail/1.4.20

Hi Stuart.  I was wondering if there is a way to add a package to the host
side without modifying the following files.


Also, is it possible to have a host-side spec file that is not in
dist/lfs-5.1?  I've got my build down to only having to put one new
directory into the LTIB, which is for my board, config/platform/my-board. 
I like that because I can update the LTIB as much as I want and not have
to touch the files I introduced.  I guess I was thinking it might be nice
to be able to add additional stuff to the host side by putting files in a
separate area like I do for the target side with the files


I noticed that when configuring the host-side the LTIB will not check the
my-board directory for spec files.  I guess that makes sense since the
LTIB builds the host packages before you even select your platform, but
maybe there could be an area to put non-standard host side mods.  Also, it
seems like

./ltib --hostcf -m listpkgsbuild

returns the packages of the target side.  I have to issue the rpm command
to view the packages installed on the host side.



> Hi Carolyn,
>    It's a different problem, we are talking about the LPC31xx NXP
> processor MMC support,
> that seems to be broken with NXP last patches (not related to MPCxxxxx)
>    For your case, dont know, try to make an ext2 partition (using fdisk,
> and then mkfs.ext2) on the SD
> card and put your rootfs inside, then at boot pass the boot parameters
> to kernel(for the 1st partition):
> root=/dev/mmcblk0p1 rootdelay=2
> Good luck!
> El 17/11/2010 17:42, Reer, Carolyn (SA-1) escribió:
>> This sounds like same problem I am having:
>> Has anyone booted the kernel from SDHC card?
>> I have 2.6.28 kernel built for Freescale MPC8536E and booting from NFS.
>> I would like to copy the kernel & file system over to SD card to
>> eliminate NFS from my Ethernet traffic timing tests.
>> I have tried 2-4GB SDHC cars and they are pre-formatted with W95 FAT16
>> partitions.
>> I can mount the partition:
>> mount /dev/mmcblk0p1 /mnt/tmp/
>> But I can't write to it.
>> I tried using fdisk to delete the partition and make a new linux
>> partition; tried changing the FAT16 partition to linux partition.
>> But I can't save the changes.%0

reply via email to

[Prev in Thread] Current Thread [Next in Thread]