[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Ltib] RE: Building xorg-x11-proto-devel: Minor proposed fix to latest c

From: Rodney Lott
Subject: [Ltib] RE: Building xorg-x11-proto-devel: Minor proposed fix to latest change in spec file.
Date: Fri, 19 Nov 2010 14:06:00 -0500


I found a similar issue and have been able to reproduce it:

+ mv COPYING COPYING-bigreqsproto
mv: cannot stat `COPYING': No such file or directory
error: Bad exit status from /home/rlott/doodles/ltib-10-1-1a-sv/tmp/rpm-tmp.88448 (%build)

If you do the -m prep and -m scbuild from a fresh install, then do another -m scbuild, you will get the error I spoke of.  In the spec file, the first part of the build goes as follows:

for dir in $(ls -1) ; do
    pushd $dir
    ./configure --prefix=%{_prefix} --host=$CFGHOST --build=%{_build}
    mv COPYING COPYING-${dir%%-*}

If you are just doing a straight ./ltib or ./ltib -p without making it keep the build directory in rpm/BUILD, then this doesn't cause any problems.  If, however, you do a ./ltib -p ... -m prep followed by subsequent -m scbuilds or a plain ./ltib, this will cause the error.  This is because LTIB will not remove the source code from rpm/BUILD and the COPYING file in each of the subdirectories has already been renamed by the "mv" command.  So, when it goes through the build a second time, there is no COPYING file anymore:

address@hidden:~/doodles/ltib-10-1-1a-sv/rpm/BUILD/xorg-x11-proto-devel-7.3/bigreqsproto-1.0.2$ ls
aclocal.m4  bigreqsproto.pc     bigreqstr.h  config.log     configure     COPYING-bigreqsproto  Makefile  mkinstalldirs  ChangeLog    config.status  install-sh    missing

So, I guess this issue is only an issue if one is doing staged commands. 

Still doesn't answer the original issue of why there were COPYING-* files in the xorg-x11-proto-devel-7.3 subdirectory, though. :-(



-----Original Message-----
From: Rodney Lott
Sent: Fri 11/19/2010 10:18 AM
To: Stuart Hughes
Cc: address@hidden
Subject: RE: Building xorg-x11-proto-devel: Minor proposed fix to latest change in spec file.

Hi, Stuart.

I just did the same test as you and got the same results!  :-S

I guess my system was either in a bad state or I gave results in mid-machinations.  Sorry about that.  I'll try to do a clean build a couple times before posting in future. 

At any rate, given that the directory only contains subdirectories, either one will do.  I'll just revert my change then.  No point disturbing something if it isn't really broken.



-----Original Message-----
From: Stuart Hughes [mailto:address@hidden]
Sent: Thu 11/18/2010 5:51 PM
To: Rodney Lott
Cc: address@hidden
Subject: Re: Building xorg-x11-proto-devel: Minor proposed fix to latest change in spec file.

Hi Rodney,

Thanks for the patch, which looks okay, however before I apply it, I'm
trying to understand why at the point that code runs there's anything
except directories.

I just ran:

./ltib -p xorg-x11-proto-devel -m prep
./ltib -p xorg-x11-proto-devel -m scbuild
cd rpm/BUILD/xorg-x11-proto-devel-7.3/

and at that point if I do: ls -1 I see:


So I'm wondering why on your build you're seeing the weird:
        pushd COPYING-bigreqsproto

Regards, Stuart

Rodney Lott wrote:
> Hi, Stuart.
> Here's a fix to the error message I found after fetching the fix to the
> xorg-x11-proto-devel.spec file:
> Index: dist/lfs-5.1/xorg-x11-proto-devel/xorg-x11-proto-devel.spec
> ===================================================================
> RCS file:
> /sources/ltib/ltib/dist/lfs-5.1/xorg-x11-proto-devel/xorg-x11-proto-devel.spec,v
> retrieving revision
> diff -a -u -r1.1.1.1 xorg-x11-proto-devel.spec
> --- dist/lfs-5.1/xorg-x11-proto-devel/xorg-x11-proto-devel.spec 5 Dec
> 2008 14:25:45 -0000
> +++ dist/lfs-5.1/xorg-x11-proto-devel/xorg-x11-proto-devel.spec 15 Nov
> 2010 16:55:34 -0000
> @@ -57,7 +57,7 @@
>  %Build
>  # Proceed through each proto package directory, building them all
> -for dir in $(ls -1) ; do
> +for dir in $(ls -p | grep "/") ; do
>     pushd $dir
>     ./configure --prefix=%{_prefix} --host=$CFGHOST --build=%{_build}
>     make
> @@ -68,7 +68,7 @@
>  %Install
>  rm -rf $RPM_BUILD_ROOT
> -for dir in $(ls -1) ; do
> +for dir in $(ls -p | grep "/") ; do
>     pushd $dir
>     make install DESTDIR=$RPM_BUILD_ROOT/%{pfx}
>     install -m 444 COPYING-${dir%%-*} $OLDPWD
> The "ls -1" will include files and directories, so using "ls -p | grep
> "/"" will just grab the directories only.  I am sure there is probably a
> better way of doing this, but this seems to work for me.
> Thanks.
> -----Original Message-----
> From: Stuart Hughes [mailto:address@hidden]
> Sent: Sat 11/13/2010 2:16 PM
> To: Rodney Lott
> Subject: Re: Builing full xorg-server: Is there a xf86dgaproto package
> Hi Rodney,
> Unfortunately the full xorg-server build is not as well tested as Kdrive.
> xorg-x11-proto-devel.spec provides xf86dgaproto, but the build order of
> these package was wrong (it needs to be built before xorg-server).
> I have checked-in a fix for this, if you do a 'cvs up -dP' and re-run
> your build it should work (I just tried).
> Regards, Stuart
> Rodney Lott wrote:
>> Hi, Stuart.
>> As you suggested, I updated my tarball to the latest in CVS and started
>> to rebuild things, which for me includes the xorg-server package.    I
>> got to this stage in the xorg-server configure step, when it failed at
>> this point:
>> checking for DGA... configure: error: Package requirements
>> (xf86dgaproto) were not met:
>> No package 'xf86dgaproto' found
>> Consider adjusting the PKG_CONFIG_PATH environment variable if you
>> installed software in a non-standard prefix.
>> Alternatively, you may set the environment variables DGA_CFLAGS
>> and DGA_LIBS to avoid the need to call pkg-config.
>> See the pkg-config man page for more details.
>> Is there a dgaproto package that would fill this requirement?  I see
>> there is a package called libXxf86dga, but I am not sure if this is the
>> correct one.  If there is, let me know.  If not, then I will proceed in
>> making one.
>> Thanks.
>> Rodney

reply via email to

[Prev in Thread] Current Thread [Next in Thread]