lwip-commits
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-commits] [SCM] lwIP - A Lightweight TCPIP stack branch, master, up


From: Simon Goldschmidt
Subject: [lwip-commits] [SCM] lwIP - A Lightweight TCPIP stack branch, master, updated. master_at_STABLE-2_0_0-407-g30be7b5
Date: Mon, 6 Mar 2017 15:54:57 -0500 (EST)

This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "lwIP - A Lightweight TCPIP stack".

The branch, master has been updated
       via  30be7b582e26da399df7f69cc7a92bc8f80bacd8 (commit)
       via  49414826afee624113ed37bd84cc5e8f5c477145 (commit)
       via  c295717ce7808c45882898ce69cb24448ed71350 (commit)
       via  1945582c107115204659077a72b8147bf27afd76 (commit)
       via  b86787c39c6c76b529a39db2671c2be43c9c5ae8 (commit)
      from  e15e5042177fc7bf78d471f5f0ef838c7f230c0c (commit)

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit 30be7b582e26da399df7f69cc7a92bc8f80bacd8
Author: goldsimon <address@hidden>
Date:   Mon Mar 6 21:54:50 2017 +0100

    sockets: remove sock->lastoffset and free unused pbufs instead (using 
pbuf_free_header)

commit 49414826afee624113ed37bd84cc5e8f5c477145
Author: goldsimon <address@hidden>
Date:   Mon Mar 6 21:53:48 2017 +0100

    pbuf: added new function pbuf_free_header() to gradually hide bytes and 
free pbufs from the front of a pbuf chain

commit c295717ce7808c45882898ce69cb24448ed71350
Author: goldsimon <address@hidden>
Date:   Mon Mar 6 21:50:42 2017 +0100

    sockets: clean up all the if/else in lwip_recvfrom and use new nonblocking 
features in netconn API: I'm OK with code duplication if it gets more readable 
:-/

commit 1945582c107115204659077a72b8147bf27afd76
Author: goldsimon <address@hidden>
Date:   Mon Mar 6 21:33:35 2017 +0100

    netconn: added receive flag NETCONN_NOAUTORCVD and netconn_tcp_recvd() to 
delay rx window updates (e.g. when receiving more data as performance 
improvement)

commit b86787c39c6c76b529a39db2671c2be43c9c5ae8
Author: goldsimon <address@hidden>
Date:   Mon Mar 6 21:27:33 2017 +0100

    Improve code readability by moving tcp-specific functionality from 
netconn_recv_data() to new static function netconn_recv_data_tcp() since all 
tcp code paths are different anyway

-----------------------------------------------------------------------

Summary of changes:
 src/api/api_lib.c       | 159 +++++++++++----------
 src/api/sockets.c       | 358 +++++++++++++++++++++++++++---------------------
 src/core/pbuf.c         |  30 ++++
 src/include/lwip/api.h  |  12 +-
 src/include/lwip/pbuf.h |   1 +
 5 files changed, 329 insertions(+), 231 deletions(-)


hooks/post-receive
-- 
lwIP - A Lightweight TCPIP stack



reply via email to

[Prev in Thread] Current Thread [Next in Thread]