[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[lwip-users] Help regarding lwip library

From: Durgaprasad Chivukula
Subject: [lwip-users] Help regarding lwip library
Date: Thu, 14 Jul 2005 14:22:12 +0200


      I tried lib, minimal , unixsim under contrib with the latest CVS
source , they got compiled successfully under redhat linux 9.0 . In
lib  example it generated the shared library liblwip.so , as per the
suggestion of a guy on this group , I want to use this shared library
to tell my tftp application to use this library for getting and
putting files , using the environment variable LD_PRELOAD , I exported
the library using this env variable and  started my tftp application ,
but its not using the library . I used strace under linux to see if my
tftp application is using this library.But its not..I tried to find
the problem , I found that there are lot of undefined symbols in that
..for example..I tried with the command

ld -v liblwip.so then I found lot of undefined references....

undefined reference to :  tapif_init 
                                sys_thread-new   etc..
there are 10 more undefined references like this ...

Does any body of you know , whats went wrong in generating the lwip
library ...Do I need to change any thing to generate a library without
any undefined library ..If I get lwip library with out any undefined
sysmbols like this , then I can use this library to tell my
application to use this library under linux ....

Please tell me , how to get a successful lwip library generated , with
out any undefined symbols... ???



reply via email to

[Prev in Thread] Current Thread [Next in Thread]