[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lwip-users] Re: reading and writing to the ethernet, unix port

From: Yadnesh Phadke
Subject: Re: [lwip-users] Re: reading and writing to the ethernet, unix port
Date: Tue, 5 Sep 2006 09:34:31 +0530

Thanks for the suggestion.
I have tried simhost sample.  I found that ping works because low_level_init() is executing ifconfig to add the ipaddress for tap0.
But, no code from simhost ever gets executed.  the read on "/dev/net/tun" does not get any data.
I have got 2 suggestions, whose feasibility I do not know.  Please comment.
1) Create a bridge between eth0 and tap0
2) instead of  tap0 do the read and write of packets on  eth0.

To answer your first question, I have  sample client-server application  using the regular Linux stack working perfectly fine. 


On 9/5/06, Kelvin Lawson <address@hidden> wrote:
> But , when I call lwip_connect(), the outgoing packet should be seen
> by,  "tcpdump - i tap0"
> Am I right?

I'm not sure what the behaviour would be when the interface is firewalled.

> But I am able to run normal socket based client-server sample on Linux.
> and also across, my Linux and  XP.

Do you mean you have a LWIP sample running or using the regular Linux stack?

Have you tried running the simhost sample in
contrib/ports/unix/proj/unixsim? If not I would suggest you start there.
Run the simhost application and attempt to ping the host at

lwip-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]