[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lwip-users] [PATCH 6/7] lwip: fix warning: 'packed' attribute ignor

From: Kieran Mansley
Subject: Re: [lwip-users] [PATCH 6/7] lwip: fix warning: 'packed' attribute ignored
Date: Fri, 21 Sep 2007 13:00:20 +0100

On Fri, 2007-09-21 at 02:29 +0000, address@hidden wrote:

> -  PACK_STRUCT_FIELD(struct ip_addr src);
> -  PACK_STRUCT_FIELD(struct ip_addr dest); 
> +  NOPACK_STRUCT_FIELD(struct ip_addr src);
> +  NOPACK_STRUCT_FIELD(struct ip_addr dest);

I'm happy with this in principle - avoiding compiler warnings, if
they're genuine, is on the whole a good idea - but I don't like the
"NOPACK" name.  How about calling it PACK_STRUCT_STRUCTFIELD instead?
Not the most elegant of names perhaps, but better defines what it's
trying to achieve.

Thanks for the other patches too - Simon and Frederic seem to have dealt
with the rest.  In general (this is not a criticism of you, just a point
for reference) attaching the patches as well as including them in the
email is best, and for the full belt-and-braces approach entering them
into the patch tracker on savannah will make sure they don't get


reply via email to

[Prev in Thread] Current Thread [Next in Thread]