[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
RE: [lwip-users] [PATCH 6/7] lwip: fix warning: 'packed' attributeignore
RE: [lwip-users] [PATCH 6/7] lwip: fix warning: 'packed' attributeignored
Fri, 21 Sep 2007 14:09:38 +0200
> > - PACK_STRUCT_FIELD(struct ip_addr src);
> > - PACK_STRUCT_FIELD(struct ip_addr dest);
> > + NOPACK_STRUCT_FIELD(struct ip_addr src);
> > + NOPACK_STRUCT_FIELD(struct ip_addr dest);
> I'm happy with this in principle - avoiding compiler
> warnings, if they're genuine, is on the whole a good idea -
> but I don't like the "NOPACK" name. How about calling it
> PACK_STRUCT_STRUCTFIELD instead?
> Not the most elegant of names perhaps, but better defines
> what it's trying to achieve.
And what about the u8_t types, then? If they also don't require packing,
we would have to define something like PACK_STRUCT_BYTE_FIELD...