lwip-users
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AW: [lwip-users] Join Multicast Group


From: Mathias Zenger
Subject: AW: [lwip-users] Join Multicast Group
Date: Wed, 15 Jul 2009 13:52:32 +0200

Hi Kieran,

Regarding the reuse option you were right. I found the following entry in
opt.h

/* ---------- Socket Options ---------- */
/* Enable SO_REUSEADDR and SO_REUSEPORT options */
#ifdef SO_REUSE
/* I removed the lot since this was an ugly hack. It broke the raw-API.
   It also came with many ugly goto's, Christiaan Simons. */
#error "SO_REUSE currently unavailable, this was a hack"
#endif

So this is the reason (missing SO_REUSE) why my call to setsockopt in
socket.c failed:

setsockopt(fd_socket, SOL_SOCKET, SO_REUSEADDR, &set_true, sizeof(set_true))

Any other version where this is implemented? (Although I am not sur if I
really need it). Still unable to join a group - I continue with debugging...

Regards,
Mathias




-----Urspr√ľngliche Nachricht-----
Von: address@hidden
[mailto:address@hidden Auftrag
von Kieran Mansley
Gesendet: Dienstag, 14. Juli 2009 16:47
An: Mailing list for lwIP users
Betreff: Re: [lwip-users] Join Multicast Group


On Tue, 2009-07-14 at 14:41 +0200, Mathias Zenger wrote:
> Since it is possible to enable LWIP_IGMP I thought
> this feature would be supported by lwIP. Does anybody have an explanation
> for the failures or can somebody even provide me a working example?

lwIP should, I think, support IGMP multicast for UDP sockets.  I haven't
done this myself, so can't help directly with a working example, but I
would first try it without binding multiple sockets to the same address.
I.e. get rid of the SO_REUSEADDR stuff, in case that is causing a
problem.

Kieran



_______________________________________________
lwip-users mailing list
address@hidden
http://lists.nongnu.org/mailman/listinfo/lwip-users






reply via email to

[Prev in Thread] Current Thread [Next in Thread]