[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lwip-users] PPP with NO_SYS=1 in an interrupt context

From: David Empson
Subject: Re: [lwip-users] PPP with NO_SYS=1 in an interrupt context
Date: Mon, 20 Jun 2011 11:18:52 +1200

Mehmet Ali Ekici wrote:
Hi David,
That information was a great help to us. We found that as you indicated the driver discards
null (00) characters.

Great. I'm glad I was able to help you get that far.

Although we have got rid of that problem we face a new one.

The peer doesn’t respond to our IPCP message which I have checked message’s sanity. I have tried the same module with windows too. Windows succeeds seting up the PPP. I have compared both only difference I see is Windows doesn’t get response to the first IPCP and resends then succeeds. Lwip doesn’t do any retransmission if it doesn’t get
response which is suprising to me.

Sorry, but I probably can't help much further with this problem. I'm very familiar with the framing format used by PPP (HDLC), since I've been using and implementing variants of HDLC for decades, but I have limited experience with PPP and haven't worked with LWIP's implementation of it.

I agree with your analysis - it looks like Windows is resending the IPCP Configure-Request, but LWIP is not.

I am wondering why the peer is not also sending its IPCP Configure-Request. It seems to be waiting until it receives one, and isn't ready to accept it when LWIP sent its first and only one, or Windows sent its second one. It is hard to tell exactly what is going on here without higher resolution timing in the Windows data dump. Windows is also attempting to configure IPv6 and Compression Control Protocol, which are rejected by the peer using LCP Protocol-Reject packets, prior to Windows retrying its IPCP Configure-Request.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]