Would anyone mind if I submit a patch to change BIG_ENDIAN and LITTLE_ENDIAN to LWIP_BIG_ENDIAN and LWIP_LITTLE_ENDIAN?
Regards, Timmy Brolin
----- Reply message ----- Från: "address@hidden" <address@hidden> Datum: tis, nov 29, 2011 21:53 Rubrik: [lwip-users] Renaming the defines? Till: "Mailing list for lwIP users" <address@hidden>
Matias Mandell wrote: > I would like to suggest that e.g. the error constant defines would be > prefixed with LWIP_ > to make them more unique. Easier porting into existing platforms and > would perhaps avoid possible mix-ups? I think that's a good idea. We already started to add the LWIP_ prefix to some defines, but I guess we didn't want to change all of them in fear of breaking too many existing ports. This is clearly not a thing to do for the 1.4.1 release, but it would be a nice-to-have for 1.5.0.
To prevent breaking existing ports or applications, a file that redefines the old style defines for backwards compatibility would be nice. As always wich such a time-consuming task, help (in the form of patches) is greatly appreciated.