[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lwip-users] netconn http server memory problem ?

From: Erkan Ersoy
Subject: Re: [lwip-users] netconn http server memory problem ?
Date: Sun, 22 May 2016 20:22:56 +0000 (UTC)

I am pinging it about 15-20 minutes no lock up so far

I will try making a simple example.

it feels like i missed a setting somewhere

From: Noam Weissman <address@hidden>
To: Erkan Ersoy <address@hidden>; Mailing list for lwIP users <address@hidden>
Sent: Sunday, May 22, 2016 10:34 PM
Subject: Re: [lwip-users] netconn http server memory problem ?


I never worked with netcon. Almost all the modules I have written are in RAW mode.
Just now I made the first module with Sockets.

I suggest running something much simpler like the echo server to start with.

Can you ping to the board ?... If you can try running  ping -t and see if it runs for
some time.


From: lwip-users <address@hidden> on behalf of Erkan Ersoy <address@hidden>
Sent: Sunday, May 22, 2016 9:59 PM
To: address@hidden
Subject: [lwip-users] netconn http server memory problem ?

I recently managed to compile and run lwip+FreeRTOS on stm32f107. I can ping my device now.

I took st example netconn httpserver and put in my project it compiled. But i cant reach http page. Connection keep resetting (wireshark show it yellow highlight). I tracked down my problem

accept_function in api_msg.c calls netconn_alloc newconn equals NULL
in netcon_alloc
  if (sys_mbox_new(&conn->recvmbox, size) != ERR_OK) {
    goto free_and_return;

sys_mbox_new doesnt equal ERR_OK
in sys_mbox_new *pxMailBox = xQueueCreate( iSize, sizeof( void * ) );  returns NULL

it seems like memory problem so I make adjusments and make
 #define configTOTAL_HEAP_SIZE ((size_t) (32 * 1024))        in FreeRTOS_config.h

#define MEM_SIZE                (10*1024)         in lwipopts.h

I played with values hoping to make it right but no luck

I tried heap_1.c throgh heap_4.c  didnt work (accept heap_3.c but after connection all my threads stopped)

I think problem is somewhere else but couldn't figure out.

Thank you

lwip-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]