[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: LYNX-DEV Re: Win32 Lynx

From: Hiram Lester, Jr.
Subject: Re: LYNX-DEV Re: Win32 Lynx
Date: Sat, 15 Mar 1997 00:18:58 -0600 (CST)

On Fri, 14 Mar 1997, Wayne Buttles wrote:

> On Fri, 14 Mar 1997, Hiram Lester, Jr. wrote:
> > Wayne, you keep implying on Lynx-dev that you have a recent copy of the
> > Win32 Lynx that fixes many of the problems, but it still isn't up. 
> > Please post it. :)
> Ok, I am sure I messed something up but here you go.  My latest stuff for
> Win32 and 386+ Lynx is up (Version 2.7ac-0.6).  Please start from the
> homepage I made for it at 
> Still no FTP or News for the 386 version.  Your mileage may (will?) vary.

Quick observations... COOL!  Drag and drop works.  I have a couple of
notes concerning drag and drop. 

First, a tip: you can hit G)oto and then drag a file into the Lynx window.
I notice that the short DOS filename gets sent in this case.  I guess this
is just the way Windows works with DOS/Console mode applications?

Second: If a shortcut is dragged and dropped on the Lynx image, it
actually opens the LNK file and not the target file.  Is this again a
limitation of Console mode?

Third: While entering E:\test.html no longer crashes it, entering E:\ or
e:/ or file:///e:\ will.  The only way to get a directory listing is to
enter file:///e:/.

ARGH, I still can't get Lynx to run my editor.  I know edit is in the
path, and I even tried specifying the full path.  I just turned on trace,
and comparing it to the unix version, I think I see what's going on.  It
runs through HTParse stripping off 'file://' and 'localhost' until it
thinks it has a valid filename and gives something like:

HTParse: Result:/users/student3/cosc/cosc0065/public_html/index.html

This is then followed by a call to LYEdit with the filename above.  The
'95 version returns the following:

HTParse: Result:/c:\test.html

The '\' can be forward or backward, but the end effect is the same.  The
leading forward slash makes it an invalid filename under DOS.  I presume
this is what is happening.  I get an Alert message about unable to access

Keep plugging!  It's improving all the time!  I'll continue using it
locally as I develop pages to keep from having to stay logged in all the
time. :)

   | Hiram W. Lester, Jr.               | E-Mail: address@hidden    |
   | Computer Science                   | Home page:                    |
   | Middle Tennessee State University  | |

; To UNSUBSCRIBE:  Send a mail message to address@hidden
;                  with "unsubscribe lynx-dev" (without the
;                  quotation marks) on a line by itself.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]