[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

lynx-dev Error/Possible Bug Report

From: Ken Scott
Subject: lynx-dev Error/Possible Bug Report
Date: Sun, 24 Sep 2000 07:36:03 -0500 (CDT)

When compiling the latest development version (2.8.4dev.10) I get the
following error:

-DLOCALEDIR=\"/usr/local/share/locale\" -I. -I.. -Ichrtrans -I./chrtrans
-I.. -I../src -I../WWW/Library/Implementation  -DUSE_SSL
-I/usr/include/openssl -I/usr/include  -O2 -DLINUX -D_GNU_SOURCE  -c
In file included from /usr/include/ucontext.h:27,
                 from /usr/include/signal.h:317,
                 from LYSignal.h:5,
                 from ./LYClean.c:4:
/usr/include/sys/ucontext.h:74: warning: `ERR' redefined
/usr/include/curses.h:200: warning: this is the location of the previous
In file included from /usr/include/ucontext.h:27,
                 from /usr/include/signal.h:317,
                 from LYSignal.h:5,
                 from ./LYClean.c:4:
/usr/include/sys/ucontext.h:73: parse error before `('
gmake[1]: *** [LYClean.o] Error 1
gmake[1]: Leaving directory `/home/admin/lynx2-8-4/src'
gmake: *** [all] Error 2

Prior to that, everything goes fine.  I have been able to install all the
releases in the 2.8.4 series with no problem, but we recently upgraded
some packages (glib, glibc, and everything glibc-related) and I suspected
this might be the problem, so I got the source for dev.9 and tried to
compile it again (there had been no problem the first time), and sure
enough, I got the same error as above.  If someone could provide me with a
fix for this, it would be very much appreciated.  The OS is Red Hat Linux


Ken Scott,

; To UNSUBSCRIBE: Send "unsubscribe lynx-dev" to address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]