[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GMG-Devel] Mediagoblin on Fedora 20 with Apache and fastcgi and/or

From: ayleph
Subject: Re: [GMG-Devel] Mediagoblin on Fedora 20 with Apache and fastcgi and/or fcgi
Date: Thu, 03 Apr 2014 07:52:41 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.4.0


The httpd error log is not available at the link provided. You have also
not provided your mediagoblin config file in which you instruct Apache
to use the fastcgi server. These would both be helpful in this

Other responses are inline below.

On 04/03/2014 03:37 AM, Danfox Davies wrote:
> Hello,
> Re: Mediagoblin on Fedora 20 with Apache and fastcgi and/or fcgi
> I have tried to get my Mediagoblin install to behave on my home server
> without any luck for weeks now. I have exhausted the knowledge of at
> least three IRC-dwelling devs and still seem unable to get Mediagoblin
> fully functional. When I tried with nginx, I had everything working
> except the displaying of images, which stubbornly refused to work. I
> tried with Apache, and got various HTTP errors eventually culminating
> in a very stubborn 500 Internal Server Error which all who I have
> asked so far seem to think is permissions related, as the error logs
> suggest.

The 500 error indicates something wrong on the server. This could be
caused by permissions, but could just as easily be caused by

> The site is at and the URL and DNS
> stuff (and some other parts of are all hosted
> externally, but do point at the server as was proven when using nginx.
> I include here links to the httpd.conf, mg.fcgi and httpd error log.
> - httpd.conf

I haven't used Apache in years, but it appears that there's an oddity at
the bottom of your Apache config file. You have included the following bit:

<Directory "/srv/">
        Order allow,deny
        Allow from all

I believe that /srv/
should be a file, not a directory. Perhaps what you meant to type was this:

<Directory "/srv/">
        Order allow,deny
        Allow from all

> - mg.fcgi

I wonder where you found this line in your mg.fcgi:
os.environ['PYTHON_EGG_CACHE'] = "/home/mediagoblin/.python-eggs"

I don't see that referenced on the wiki Deployment page. What caused you
to include it?

> - httpd error log

As mentioned above, this is a broken link.

> I do not know if all dependencies are fulfilled as it is not made
> clear in the documentation. I am the first to admit I am a bit of a
> n00b, but tell me to RTFM (without first editing it heavily) and I
> will scream, TFM is not Fing clear enough or even complete,
> particularly with regard to RPM-based distros and fastcgi or fcgi. Yes
> I will contribute to TFM if I ever get to TFing bottom of this and
> have a working install the means to the obtainment of which I am
> sufficiently capable of getting my head round (and that is a big caveat).

TFM will not and cannot cover everyone's distro, http daemon, and file
system in complete detail. If you're having trouble with Apache and
fastcgi, you'd do well to read Apache's documentation on those subjects
to familiarize yourself with configuration.

> We have already tried:
> (LONG chat log from IRC)
> and also several other things in 2 other chats I failed to copy the
> text from.

Most of what I gathered from skimming over the logs looking for text
relevant to your issue is that you were experiencing Apache
configuration issues. Perhaps if you include the httpd error log and the
Mediagoblin configuration file (conf.d/mediagoblin.conf?), we can get a
better picture of the problem.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]