[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [monit] Problem Running Monit on Solaris 10

From: Martin Pala
Subject: Re: [monit] Problem Running Monit on Solaris 10
Date: Tue, 15 Jan 2008 06:34:30 -0800

In the case that you are using the 64 bit binary, the path to the ssl
libraries has to be set. For example adding the path to the Solaris
bundled ssl libraries:

  crle -64 -l /lib/64:/usr/lib/64:/usr/sfw/lib/64

When you use crle without the -64 option, you set the library path for 32-bit binaries.


On Jan 12, 2008, at 9:01 PM, Andrew Ohnstad wrote:

Hi all,

First time monit installer here...  Running on an x86 Solaris machine.

I installed monit from the "official" solaris package...

address@hidden:/etc# pkginfo|grep -i monit
application GNUmonit                     monit

But when I run monit I get:

address@hidden:/etc# /usr/local/bin/monit -c /etc/monitrc monit: fatal: open failed: No such file or directory

I have libssl as so:

address@hidden:/etc# find / -name

Originally I did not have the 'amd64' library path added, so i added it before the standard one:

address@hidden:/etc# crle

Configuration file [version 4]: /var/ld/ld.config
Default Library Path (ELF): /lib:/usr/lib:/usr/sfw/lib/amd64:/ usr/sfw/lib Trusted Directories (ELF): /lib/secure:/usr/lib/secure (system default)

But still no joy.

address@hidden:/etc# file /usr/local/bin/monit
/usr/local/bin/monit: ELF 64-bit LSB executable AMD64 Version 1 [SSE2 SSE FXSR FPU], dynamically linked, stripped

address@hidden:/etc# file /usr/sfw/lib/amd64/
/usr/sfw/lib/amd64/ ELF 64-bit LSB dynamic lib AMD64 Version 1, dynamically linked, not stripped, no debugging information available

Any ideas before I pull the package and reinstall from source?

To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]