[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [monit] Compiling monit on Solaris9

From: Jan-Henrik Haukeland
Subject: Re: [monit] Compiling monit on Solaris9
Date: Wed, 26 Mar 2008 13:24:27 +0100

On 26. mars. 2008, at 13.03, SMITH Duncan wrote:
I get the following error: monit: fatal: open failed: No such file or directory

I have the library file in /usr/local/ssl/lib.

I have tried setting the --with-ssl-dir option to various other settings such as "/usr/local/ssl" "/usr/local/ssl/bin" etc.

Looks like the runtime linker (ld) cannot find the ssl library. Its been a long time since I used Solaris, but I believe you can export this environment variable, so the dynamic linker will find the ssl library.

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/ssl/lib

Or if Solaris has a ld configure file, such as /etc/ you can add the ssl library there so you do not have to set the environment variable mentioned above.

Ps. This means that other applications using ssl should get the same error. Do they?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]