[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [monit] Unable to Install Monit 5.0 Beta1

From: John Timms
Subject: Re: [monit] Unable to Install Monit 5.0 Beta1
Date: Wed, 23 Jul 2008 09:35:34 -0400

Monit specifically requested flex when I ran ./configure. Then it requested yacc when I ran make. Yacc is included in btyacc, byacc, and bison, all of which I have tried. Is flex supposed to include yacc?

On Wed, Jul 23, 2008 at 9:31 AM, Brian Downey <address@hidden> wrote:
On Jul 23, 2008, at 6:19 AM, John Timms wrote:

I'm trying to install Monit 5.0 Beta 1 on a completely clean Ubuntu Server. It fails at the make command. This is what I've done, in chronological order:


  byacc -dt p.y
  byacc: f - cannot open ""
  make: *** [] Error 2

If I remember correctly, I ran into this identical problem when building on some HP-UX servers.  The solution for us was to use flex instead of bison, I just couldn't get bison to work at all.  The monit build only needs one or the other.

Hope that helps...


To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]