[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[monit] monit fails mysteriously on refresh after upgrade from Debian et

From: Jenny Hopkins
Subject: [monit] monit fails mysteriously on refresh after upgrade from Debian etch to lenny
Date: Mon, 23 Feb 2009 15:32:08 +0000

Hullo list,

After upgrading from etch to lenny, monit won't run for more than one cycle.
It is started from /etc/init.d - starts fine, runs through all its
tests, the process sleeps.
When it reaches time to check again, it just dies.  I've changed
timings from wait 180 secs to wait 10 secs/20 secs etc, and always the

It's not likely the monitrc file, because I've tried using the setup
with the empty file supplied and only the very basics put in such as
server and logfile - no checking to do.

I tried running an strace on it, and this gives an enormous output,
but I don't know what to look for.
Also the trace runs while monit is still up.
Something like this line could be a clue, but could also be a red herring:
access("/etc/", F_OK)      = -1 ENOENT (No such file or directory)

I'd have thought if it were a library problem monit wouldn't even
start in the first place.

Can anyone give me a hint as to what exactly happens when monit
refreshes, rather than starts?

I'm at the hair-tearing out stage....

Files can be supplied.  Monit version is 1:4.10.1-4.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]