[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [monit] cpu usage check skipped (initializing)... always stuck at in

From: Joshua Smith
Subject: Re: [monit] cpu usage check skipped (initializing)... always stuck at initializing
Date: Mon, 28 Dec 2009 23:29:34 -0800

Thank you very much for the reply! This is a physical machine, not virtual. File monit returns:
monit: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.8, not stripped

After i enabled the web interface cpu usage monitoring decided to start working, is that supposed to be a requirement?

On .Mon, Dec 28, 2009 at 11:46 AM, Martin Pala <address@hidden> wrote:

is the machine where monit is running physical system or some virtual host? Monit <= 5.0.3 had had problem to monitor process cpu/memory usage in some virtual environments (like Linux Vserver) which either do not present whole process tree or doesn't show PID 1. This is fixed in next version (5.1). To get more details about what's going on you can run Monit in verbose mode:

monit -vI

As you mentioned that your platform is x64, make also sure that Monit is compiled with 64-bit support to be able to get correct data about 64-bit processes. You can verify it with "file" command:

file monit


On Dec 28, 2009, at 6:44 AM, Joshua Smith wrote:

> Hello everyone, running debian lenny x64 monit seems unable to determine the cpu usage of any process, no matter what process i try to montitor (apache, srcds_i686) it returns cpu usage check skipped (initializing) or total cpu usage check skipped (initializing) the result is always (initializing). I have tried running as root or as user, i tried the package maintainers version, then compiled 5.0.3 and got the same result. Any help is greatly appreciated as this has been driving me up the wall.
> --
> To unsubscribe:

To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]