[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Verifying version compatibility

From: Martin Pala
Subject: Re: Verifying version compatibility
Date: Fri, 1 Oct 2010 14:25:25 +0200


M/Monit 2.2.x supported Monit versions 5.0.x - 5.1.x.

When you upgrade to M/Monit 2.3, the upgrade of Monit agents which are managed 
by it to 5.2.x or newer is required at the same time.

We provide pre-compiled Monit binaries for common platforms to make the upgrade 
easier as the Monit packages in various Linux and BSD distributions are not 
updated instantly - it takes usually some time to 3rd party to upgrade the 
package (with the exception of development Debian version and FreeBSD port). 
The Monit binaries are available in the download page along with the source 

The reason why Monit 5.2.1 doesn't work with previous M/Monit versions (such as 
2.2) are changes in the protocol which is used between Monit and M/Monit.


On Sep 30, 2010, at 9:34 PM, Yahoo - Tjstroker wrote:

> Hello,
> I just wanted to verify something. Docs say monit 5.2 is required for m/monit 
> 2.3. Does the same hold true for the previous version of m/monit and 5.1? 
> Does monit and m/monit require updating at the same time?
> I ask as I just setup m/monit maybe two weeks ago, with the previous release, 
> and tried to use monit 5.2.1 with it. It cannot seem to register with the 
> previous release even if i tell it to skip the new auto authenticating 
> feature.
> Just wanted to make sure I understood the upgrade requirements correctly.  
> Thank you,
> Jim
> --
> To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]