[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Failing to restart a process

From: Marc Cooper
Subject: Re: Failing to restart a process
Date: Wed, 29 May 2013 14:54:41 +0100
User-agent: Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20130510 Thunderbird/17.0.6

Hi Martin,

> there could be problem with two checks, restarting the same process:
> when the "stream_restart" tries to restart the process, the
> "stream_reader" will detect that the process is not running and will
> try to restart it too (since there is no connection between these two
> tests). The restart should be either performed via dependency chain,
> or exec action which will restart the service with process check:

check file stream_restart with path
    if changed timestamp then exec "/usr/bin/monit restart stream_reader"

Thanks so much for this. It worked.

That was a really annoying problem so I'm delighted to have it solved.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]