[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Space in path results in error

From: James Alton
Subject: Re: Space in path results in error
Date: Thu, 3 Oct 2013 23:51:28 -0400

My apologies, I somehow got screwed up between testing the issue and writing the e-mail. The issue isn't with the path but with the name given to the filesystem.

check filesystem James Shows with path "/mnt/user/James Shows" fails with error  "Error: syntax error 'Shows' "

I assumed it was failing on the path but it appears it fails with the filesystems name. I have also tried escaping the space and surrounding the name in quotes.

On Thu, Oct 3, 2013 at 11:23 PM, Jan-Henrik Haukeland <address@hidden> wrote:
Quoting the path should work. Verified and tested with Monit 5.6. E.g.

check file x with path "/mnt/user/James Shows" ...

Den 3. okt. 2013 kl. 03:58 skrev James Alton <address@hidden>:

I run an unraid server that aggregates top level directories on harddrives into "shares", which basically act as drives. I'm trying to set Monit up to monitor the available disk space for these shares which works well for most shares. The path looks something like:

If the path has a space, Monit fails to start giving the error "syntax error 'Shows'

This happens when trying to add the path:
/mnt/user/James Shows

I have tried to escape the space as such:
/mnt/user/James\ Shows

I have also tried using quotes:
"/mnt/user/James Shows"

Is there any way to add a path with a space or is this a bug that needs to be resolved?

To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]