[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How to run bash script?

From: address@hidden
Subject: Re: How to run bash script?
Date: Thu, 20 Mar 2014 17:18:48 +0200

Did you set the permission of the script ? And added #!/bin/bash

Sent from my iPhone 5

On 20 Mar 2014, at 4:09 PM, Martin Vaner <address@hidden> wrote:

Same problem. The console output is:

address@hidden:/mnt/vouchers# sh /usr/local/bin/

Monit is saying:

failed to execute '/etc/monit/scripts/contego_logtest' -- Exec format error

I do not know more what can i do.

Dne 20.3.2014 14:45, admin-at-extremeshok-dot-com napsal(a):
Should work ;-P

errorcount=`tail -n 10 /mnt/vouchers/contego.log | grep "Error" | wc -l`
if [ $errorcount -gt 0 ] ; then
  echo "OK working"
  exit 0
  echo "$errorcount" 1>&2;
  exit 10

On 3/20/2014 3:39 PM, Martin Vaner wrote:
Hello all,

i have a one question.
I am using monit to monitor all of our servers all around the world, but i have a little problem in this moment.

I need to monitor one log file using external bash script (

errorcount=`tail -n 10 /mnt/vouchers/contego.log | grep "Error" | wc -l`
if [ $errorcount -gt 0 ]; then
exit 0;
exit $?;

So, when i run this script from the console, it is working fine. I tried to do test in the monitrc file, as described here: (monit official how to):

check program contego_errors with path /usr/local/bin/
    if status != 0 then alert

I also tried to put quotes in the path, but monit still getting this error:

Failed to execute '/usr/local/bin/' -- Exec format error

Do you have some tips & tricks, how can i run this script to test what i need? I also tried something like:

"/bin/bash '/usr/local/bin/'" and any other combinations of "" and '' ... And i am still getting the same error.

Thank you,



To unsubscribe:

To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]