[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Execution failed

From: Martin Vaner
Subject: Re: Execution failed
Date: Wed, 09 Jul 2014 19:51:49 +0200
User-agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0

Hi Anthony, hello all,

the chmod of the file is 0755.
The output of the monit -vv:

Process Name             = contego
 Pid file                         = /home/sms/vouchers/
 Monitoring mode      = active
 Start program            = '/home/sms/vouchers/' as uid 1000 as gid 1000 timeout 30 second(s)
 Stop program             = '/home/sms/vouchers/' as uid 1000 as gid 1000 timeout 30 second(s)
 Existence                    = if does not exist 1 times within 1 cycle(s) then restart else if succeeded 1 times within 1 cycle(s) then alert
 Pid                              = if changed 1 times within 1 cycle(s) then alert
 Ppid                             = if changed 1 times within 1 cycle(s) then alert

The problem with log is the monit says the same - Execution failed - there. As you can see:

[UTC Jul  9 17:45:21] error    : 'contego' process is not running
[UTC Jul  9 17:45:21] info     : 'contego' trying to restart
[UTC Jul  9 17:45:21] info     : 'contego' start: /home/sms/vouchers/
[UTC Jul  9 17:45:51] error    : 'contego' failed to start

It is very interresting.

On 9. 7. 2014 19:39, Anthony Griffiths wrote:
hi I'm no expert on this but I use:
# chmod 755 /path/to/
also, when it says 'Execution failed' are you getting this in the console or in monit.log?. Have you tried running monit in debig mode? (it shows a lot more detail)
eg: #monit -vv

On Wed, Jul 9, 2014 at 6:04 PM, Martin Vaner <address@hidden> wrote:
Hi there.
I just have a little problem. Monit does not want to start my bash script, and i do not know why, monit is saying only "Execution failed" so i cant identify what is causing my problem.

Information about script:

if [ -f /home/sms/vouchers/ ]
echo 'process already running'
java -Xmx1024m -jar jacon2.jar &
pid_number=`ps -e -o pid,command | grep "jacon2.jar" | grep -v "\<grep\>"`
echo $pid_number >

File permissions:
-rwxr-xr-x 1 sms sms 256 Jul  9 16:46

Monit config file:
check process contego with pidfile /home/sms/vouchers/
    start program = "/home/sms/vouchers/"
          as uid "sms" and gid "sms"
    stop program = "/home/sms/vouchers/"
          as uid "sms" and with gid "sms"

When i run my script directly from console, the script is working without any issues.
This is another problem what i have encountered before.

Thank you for tips.

Regards, Martin

To unsubscribe:

To unsubscribe:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]