[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Monit won't monitor my program

From: chinaboy
Subject: Monit won't monitor my program
Date: Wed, 17 Sep 2014 07:07:05 -0700 (MST)

Hi all.
Have been struggling with this for the past few days. I have program on my
 VPS and for some reason I can't get Monit to recognize it. I reached out to
 the developer of the program for some assistance but they have provided
 little help. I had difficulty locating the process so they told me to run
 the command "ps aux | grep ProxyServer" and below is what it produced.
address@hidden:~# ps aux | grep ProxyServer
  root     31793  5.6 44.1 1211704 221868 ?      Sl   08:48   0:14
 ./jre1.6.0_16/bin/java -Xmx384m -cp

 -Djava.awt.headless=true SecureRunner1
  root     32070  0.0  0.1  11744   896 pts/0    S+   08:52   0:00 grep
 --color=auto ProxyServer
Below is what I currently have in my montitrc file and script. Monit status
 just says "Execution Failed" Please help me configure this. Nothing I tried
 has worked. I tried adding "echo $$ > /opt/SimpleHelp/; " to
 my script to create the PID file. It creates the file but still doesn't
 work.  The developer said that the PID is stored in the file ssport but I
 still can't get monit to work. Please help.
check process SimpleHelp with path /opt/SimpleHelp/ssport
     start program = "/etc/init.d/simplehelp start"
     stop program = "/etc/init.d/simplehelp stop"
In my bash file I have.
case "$1" in
      cd $SHELPDIR ; sh ./
      cd $SHELPDIR ; sh ./
      cd $SHELPDIR ; sh ./
      cd $SHELPDIR ; sh ./
      cd $SHELPDIR ; sh ./
      cd $SHELPDIR ; sh ./

View this message in context:
Sent from the monit-general mailing list archive at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]