[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Monotone-devel] [PATCH] parent selector 'p:xxx'

From: Ethan Blanton
Subject: Re: [Monotone-devel] [PATCH] parent selector 'p:xxx'
Date: Sat, 6 Oct 2007 18:02:05 -0400
User-agent: Mutt/1.5.13 (2006-08-11)

Nathaniel Smith spake unto us the following wisdom:
> > Of course, there is really no reason this can't be handled as a shell
> > alias or simple script, either...
> Except that making users write their own code to fix our bugs is
> stupid :-).

Of course.  :-)

> 'summarize' still seems too long to type conveniently.  Would 'show'
> be too generic?

I don't think it's too generic, necessarily, as I think one normally
associates generic commands with operations on revisions, but it sort
of seems funny in the presence of show_conflicts.  I thought of
'view', but that's not so much a command to be performed as an action
to be taken by the user, which might be a metaphor shear.

The name might be a bikeshed issue.  ;-)


The laws that forbid the carrying of arms are laws [that have no remedy
for evils].  They disarm only those who are neither inclined nor
determined to commit crimes.
                -- Cesare Beccaria, "On Crimes and Punishments", 1764

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]