[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Nano-devel] [Info-nano] [ANNOUNCE] nano-2.6.2 is released
From: |
Benno Schulenberg |
Subject: |
Re: [Nano-devel] [Info-nano] [ANNOUNCE] nano-2.6.2 is released |
Date: |
Fri, 29 Jul 2016 13:28:54 +0200 |
> 2016.07.28 - nano 2.6.2 "Le vent nous portera"...
Adding a more detailed overview of the commits, a sorted shortlog.
Changes between v2.6.1 and v2.6.2:
----------------------------------
Benno Schulenberg (81):
browser: elide another call of opendir()
browser: trim all trailing slashes (just in case there are more)
build: refresh the git description whenever something is recompiled
build-sys: ignore the revision header file
bump version numbers and add a news item for 2.6.2
chars: delete a now-unused function
chars: don't try to see a character in an empty line
chars: invalid sequences are not blank, nor text, nor punctuation
chars: look at bytes in their context, so only valid sequences are
accepted
chars: measure invalid sequences and unassigned codepoints more quickly
chars: plug a gushing memory leak
chars: represent the high-bit controls more intelligibly
chars: speed up the determination whether something is a control character
chars: speed up two reverse-searching routines a bit
chars: the representation of a control character is always two bytes
color: forget about aborting the precalculation for multiline regexes
color: integrate the hilite attribute into the pair number
color: push the resets further when start and end match are equal
color: refresh the screen whenever the active syntax changes
credits: don't bother blanking the second line nor the help lines
debug: remove duplicate information
files: beep whenever writing out a file fails
input: accept only the four iTerm sequences that actually get handled
input: add some missing keycodes to the parsing routine
input: consider only O, o and [ as starters of multi-character sequences
input: don't crash when the window is resized during verbatim input
input: don't drop a keystroke on the floor when the terminal resizes
input: don't drop the first byte when user starts typing during loading
input: elide an extra buffer for inserting stuff into the text
input: plug a memory leak
input: report keystroke M-[ as being unbindable instead of just unbound
input: treat Ctrl+Alt+key different from Esc followed by Ctrl+key
moving: don't do an automatic smart home with Ctrl+Up and Ctrl+Down
new feature: add the option --wordchars, to set extra word characters
new feature: functions to jump to previous or following block of text
po: update translations and regenerate POT file and PO files
screen: again, look at the bytes in their context
screen: avoid converting each character twice from multibyte to wide
screen: avoid looking up the width of whitespace and control codes
screen: don't check for every character whether there is still enough
space
screen: don't simulate a sigwinch but directly reinitialize the screen
screen: elide another intermediate buffer for every visible character
screen: elide the intermediate buffer for every single character
screen: include a workaround only when compiling against older ncurses
search: match a beginning-of-line anchor just once per line
tweaks: adjust a comment for removed definitions
tweaks: adjust a couple of comments
tweaks: adjust indentation after the previous change, and edit comments
tweaks: avoid a runtime error when compiled with -fsanitize=undefined
tweaks: avoid two compiler warnings
tweaks: compute the sizes of the subwindows in a more direct manner
tweaks: correct a comment
tweaks: delete an element that is always FALSE and never used
tweaks: don't bother resetting the Unicode code holder
tweaks: don't call a thing malloc... when it doesn't call malloc()
tweaks: elide a bit of code duplication
tweaks: elide a typedef, as it now has just one element
tweaks: elide two unneeded variables
tweaks: factor out a common condition
tweaks: fix compilation with --enable-tiny
tweaks: fuse two handlings of a delete key, and fix a comment
tweaks: improve a few comments
tweaks: improve two comments
tweaks: move a debug statement to its proper place, and improve aspect
tweaks: put all the movement functions together
tweaks: put similar things together
tweaks: put some case labels closer to their statements
tweaks: put the case labels (the keycodes) in a more sensible order
tweaks: rearrange a function in my style, and rename a variable
tweaks: reduce the scope of two variables
tweaks: rename another variable, for aptness
tweaks: rename a variable and a type, to be less confusing
tweaks: rename a variable to be more accurate
tweaks: rename a variable, to clarify it refers to columns, not to bytes
tweaks: rename a variable -- to match others and to be more concise
tweaks: rename two variables, to match others
tweaks: shuffle the resetting of a counter to the tail of the routine
tweaks: straighten out the flow of a loop
tweaks: trim some comments, and simplify a condition
tweaks: use mallocstrcpy() instead of strdup(), for a graceful death
utils: don't bother to check line and column for NULL
David Lawrence Ramsey (1):
input: provide feedback on the Unicode digits typed so far
Dirkjan Ochtman (1):
syntax: allow capital letters in Rust struct/trait names
Rishabh Dave (4):
browser: elide a variable by fusing the uses of 'newpath' and 'path'
browser: select an inaccessible directory also when tabbed
tweaks: reduce the number of wattron/wattrof calls
utils: accept mistypings and common separators between line and column
--
http://www.fastmail.com - Or how I learned to stop worrying and
love email again