[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Nano-devel] Should we rename and untypedef nano's structs?

From: Benno Schulenberg
Subject: Re: [Nano-devel] Should we rename and untypedef nano's structs?
Date: Sun, 19 Aug 2018 20:57:17 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.9.1

Op 19-08-18 om 16:30 schreef Devin Hussey:
> nano's struct types are weird, and the typedefs are inconsistent with
> the snake case and themselves. Some of them are extremely confusing.

What's "snake case"?

But true, nano's structs are poorly named and confusing.

> filestruct is a useless typedef that saves a single space, and doesn't
> represent a file itself, rather a line/node.
> openfilestruct is the actual filestruct.
> sc is shortcut, but it doesn't look like it.

All three true.

> subnfunc... what the hell does subn mean?

I have no idea.

> So my ideas:
> filestruct -> struct node, struct line
> openfilestruct -> struct file, struct open_file, struct buffer
> sc -> struct kbd_shortcut, struct shortcut
> [...]

What they should be renamed to, I don't know.  And we won't
rename them all at once.  One at a time.


Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]