[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Nano-devel] Should we rename and untypedef nano's structs?

From: Benno Schulenberg
Subject: Re: [Nano-devel] Should we rename and untypedef nano's structs?
Date: Mon, 20 Aug 2018 19:40:06 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.9.1

Op 19-08-18 om 22:38 schreef Devin Hussey:
> Benno, what are your thoughts?
> For the reference, here is a before/after comparison (also removed
> malloc casts because we need a C compiler for gnulib anyways)

If there are any more of these nmalloc casts, please send a patch
that removes them all in one go -- a patch that does only that.

> filestruct *make_new_node(filestruct *prevnode)
> [...]
> struct node *make_new_node(struct node *prevnode)

I like it that the type of anything is given by a single word.
So I want to keep the typedefs.

But several of those things could be named better.  I have
long wanted to rename "filestruct" to "linestruct", but never
gotten around to it -- although I have used that word in a
few comments.


Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]