[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #31080] User scripts or functions created duri

From: Rik
Subject: [Octave-bug-tracker] [bug #31080] User scripts or functions created during a session are not found
Date: Fri, 03 Jan 2014 22:25:04 +0000
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0

Update of bug #31080 (project octave):

                  Status:               Need Info => Confirmed              
                 Release:                   3.6.0 => 3.8.0                  


Follow-up Comment #7:

Very definitely confirmed.  Octave seems to be caching the contents of a
directory on start-up and then never updating the cache.  This could be down
to differences in how the operating system updates the inode timestamp for the

On Linux, creating a new file in a directory updates the timestamp.  I think
Octave is comparing the current directory timestamp against the cached
timestamp to figure out if it needs to go and re-read the directory.

On Windows, creating a new file in a directory does not change the
timestamp--I know because I tried.  However, I have the UNIX tool touch.exe
installed and when I touch the directory to bring the timestamp up to the
current time then Octave correctly finds the new m-files.

This sequence worked:

cd e:\
mkdir tmptst
cd tmptst
edit junk.m
## Add some code to junk.m in the editor and then quit
which junk.m
## Returns nothing
## Now, in another shell window execute touch e:\tmptst
which junk.m
'junk.m' is the file e:\tmptst\junk.m

Seems like it might require a lot of O/S specific code to solve this one.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]