[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #41146] fsolve failure

From: John W. Eaton
Subject: [Octave-bug-tracker] [bug #41146] fsolve failure
Date: Thu, 09 Jan 2014 15:27:04 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130917 Firefox/17.0 Iceweasel/17.0.9

Update of bug #41146 (project octave):

                  Status:                 Invalid => None                   
             Open/Closed:                  Closed => Open                   
                 Release:                   3.4.3 => dev                    
                 Summary: Different results for fsolve in version 3.4.3 vs.
3.2.4 => fsolve failure         


Follow-up Comment #7:

The algorithm has changed several times.  In Octave 3.0.x, Octave used
MINPACK.  In 3.2.x, Jaroslav rewrote fsolve as a .m file.  With 3.2.4, fsolve
does max out on iterations, but it also gets close to the solution.  With
3.6.4, it maxes out on iterations but is nowhere near the solution.  When we
switched from MINPACK to Jaroslav's fsolve, we noticed that a number of
problems that MINPACK could solve could not be solved by the new fsolve.  Some
of those were fixed, others are still problems.  FWIW, I tried 3.0.5 with the
problem in this report and it failed.

It appears that Matlab now offers several different solvers under the function
name fsolve (selected by an option) and that the default solver can solve this
problem.  So I reopened this bug report, changed the release to "dev", set the
item group to incorrect result instead of regression, and changed the summary
to just be "fsolve failure"


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]