[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #41099] octave-mode in emacs doesn't launch in

From: John C Frain
Subject: [Octave-bug-tracker] [bug #41099] octave-mode in emacs doesn't launch inferior mode
Date: Tue, 04 Mar 2014 20:27:52 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/32.0.1700.107 Chrome/32.0.1700.107 Safari/537.36

Follow-up Comment #4, bug #41099 (project octave):

I had a similar problem with Octave 3.8.0 and Emacs 24.3.1 in Ubuntu 13.10
(64bit). I could run Octave in shell mode but every time I tried to start an
inferior octave process (either by submittinf part of a .m file or by M x
run-octave) Emacs froze The emacs process had to be ended using System
Monitor. The "--no-gui" solution had no effect (as expected in 3.8 where the
GUI is not the default).

I had  the same problem with the MXE build of octave in Windows 7 with emacs
24.3.1 and octave 3.8.0. 

As System Monitor showed that Octave had started but appeared to lose contact
with Emacs I decided to experiment with the Octave font. I added

PS1(">> ")

to my .octaverc file in my home directory and  

(setq inferior-octave-prompt ">> ") 

to my .emacs file.

This solved the problem in both Ubuntu and Windows. It would appear to me that
the installation of version 3.8 changed the prompt causing Emacs to lose
contact with Octave in both Windows and Ubuntu.

Earlier I had tried to revert to 3.6.4 in Windows (simple change of path in
Windows). Earlier I think (but I am not absolutely sure) that I was able to
start an inferior Octave process. After changing the path so that emacs would
load 3.6.4 Emacs again froze. Has the installation of 3.8 change some of the
prompt defaults? Perhaps someone with a better knowledge of Octave Emacs 
Octave mode has an answer.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]