[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #43319] Octave dev version fails to build with

From: Philip Nienhuis
Subject: [Octave-bug-tracker] [bug #43319] Octave dev version fails to build with --enable-64
Date: Sun, 04 Jan 2015 10:56:30 +0000
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 SeaMonkey/2.30

Follow-up Comment #25, bug #43319 (project octave):

@richard (comment #24)

You've done a lot of work which at first sight shouldn't have been needed. One
of the issues you correctly mention is lack of documentation.

The easiest would (should) have been to build a 64-bit Octave using
mxe-octave; that would have saved you lots of work as mxe-octave builds all
the required dependencies for you w. 64-bit indexing. See comment #13 in this

JWE didn't tell there how to get it installed (AFAIK on Linux Octave has
hard-coded paths, contrary to Windows where Octave also has hard-coded paths
but relative to a relocatable Mingw/MSYS installation); but I suppose this is
a matter of proper PREFIX stuff and maybe it's even easier.

That said, last week I tried this (building a Linux 64-bit idx. Octave) with
mxe-octave (for bug #43908) but already at the very start I ran into issues,
i.e., when building pkg-config (its configure couldn't get gcc to work). ATM I
have no time/priority to sort that out sufficiently for a bug report; maybe my
Linux distro is the issue here (mageia-4 64b, almost out-of-support, 4.1 is
current). I'll pickup there later on.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]