[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #44186] print command gives incorrect postscri

From: Dan Sebald
Subject: [Octave-bug-tracker] [bug #44186] print command gives incorrect postscript file
Date: Wed, 18 Feb 2015 18:14:59 +0000
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0 SeaMonkey/2.15

Follow-up Comment #58, bug #44186 (project octave):

ghostscript developers have updated their repository and requested someone


I've found a couple ways to get the source.  The git ghostscript repository is
quite big.  Also, ghostscript is the gs subdirectory of a bigger project.  To
get a snapshot of the head of just the gs subdirectory, go to


(Or just sort of navigate around the "tree" from the changeset diff listed
above until within the "gs" subdirectory.)  When within the source tree for
the "gs" subdirectory, look for the widget that says "snapshot" at the second
or third line on the page.  That will give you a tar file to use.

Extract the archive then run "autogen.sh" within the source code.  I ran into
a problem in which none of the automake tools were visible, e.g.,:

configure: error: cannot find install-sh, install.sh, or shtool in "." "./.."

I created links for the following three utilities:

ln -s /usr/share/automake-1.11/install-sh
ln -s /usr/share/automake-1.11/config.sub
ln -s /usr/share/automake-1.11/config.guess

and "autogen.sh" followed by "configure" (probably redundant) followed by
"make" worked for me.

All I need to do to test in Octave environment is rename my "/usr/bin/gs" file
and create a link to the newly generated "gs" executable.

Please let me know if anyone else has compilation problems and needs to make
the fix I did.

If one wants the whole repository, try:

git clone git://git.ghostscript.com/ghostpdl.git

Again, that takes a while to download and is between 100 and 200 MB worth.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]