[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #55275] Qt5.12 adjustment

From: Ben Abbott
Subject: [Octave-bug-tracker] [bug #55275] Qt5.12 adjustment
Date: Sun, 23 Dec 2018 23:56:03 -0500 (EST)
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_2) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0.2 Safari/605.1.15


                 Summary: Qt5.12 adjustment
                 Project: GNU Octave
            Submitted by: bpabbott
            Submitted on: Sun 23 Dec 2018 11:56:02 PM EST
                Category: Configuration and Build System
                Severity: 3 - Normal
                Priority: 5 - Normal
              Item Group: Build Failure
                  Status: None
             Assigned to: None
         Originator Name: Ben Abbott
        Originator Email: 
             Open/Closed: Open
         Discussion Lock: Any
                 Release: dev
        Operating System: Any



Qt 5.12 has made a change which requires a change to the build process

In addition, we have done some cleanups in version 5.12. We got rid of an
ancient porting tool called qhelpconverter. We have merged the
qcollectiongenerator tool into the qhelpgenerator, which now accepts both .qhp
and .qhcp files as input and generates .qch and .qhc files, respectively.

My impression is that this can be handled by setting up the environment
property. For example,


However, when I tried to validate the approach, using qt 5.12.0, it failed

Build Octave Qt GUI:                  no (missing:qcollectiongenerator)
 JIT compiler for loops:               no
 Build Java interface:                 yes
 Build static libraries:               no
 Build shared libraries:               yes
 Dynamic Linking API:                  dlopen
 Include support for GNU readline:     yes
 64-bit array dims and indexing:       yes
 64-bit BLAS array dims and indexing:  no
 OpenMP SMP multithreading:            no
 Truncate intermediate FP results:     yes
 Build cross tools:                    no
 Build docs:                           yes

configure: WARNING: Your installation of Qt version 5 appears incomplete or
broken in some way.  Fix that or use --with-qt=VER to use another version.
configure: WARNING: one or more of the Qt utilities moc, uic, rcc, lrelease,
qcollectiongenerator, and qhelpgenerator not found; disabling Qt GUI
configure: NOTE: Libraries or auxiliary programs may be skipped if they are
not found
configure: NOTE: OR if they are missing required features on your system.

which is the same result I obtained without setting QCOLLECTIONGENERATOR


Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]