[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Octave-bug-tracker] [bug #56741] Octave says "error while loading share

From: Archisman Panigrahi
Subject: [Octave-bug-tracker] [bug #56741] Octave says "error while loading shared libraries: libopenblas.so.0:"
Date: Sun, 11 Aug 2019 12:56:53 -0400 (EDT)
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Follow-up Comment #2, bug #56741 (project octave):

There is some sort of bug in the libblas.so and liblapack.so provided by the
libopenblas-dev package
(https://packages.ubuntu.com/bionic/armhf/libopenblas-dev/filelist). I tried
to run a c program that uses blas, and got the same error.

I configured update-alternatives to use blas instead of openblas for
libblas.so and liblapack.so 

(sudo update-alternatives --config libblas.so.3-arm-linux-gnuabihf && sudo
update-alternatives --config liblapack.so.3-arm-linux-gnuabihf). 

Now octave works and so does my c program.


Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]